summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-04-29 18:49:09 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-29 18:49:24 +0300
commit0780b3f81f5738adb6b372a3395423be3bde181d (patch)
treec1ba42203ae8138e6afb9b8955c9103cb14f2a39 /app-editors
parentapp-emulation/qemu: Stabilize 8.0.5 x86, #914827 (diff)
downloadgentoo-0780b3f81f5738adb6b372a3395423be3bde181d.tar.gz
gentoo-0780b3f81f5738adb6b372a3395423be3bde181d.tar.bz2
gentoo-0780b3f81f5738adb6b372a3395423be3bde181d.zip
app-editors/featherpad: add 1.5.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/featherpad/Manifest1
-rw-r--r--app-editors/featherpad/featherpad-1.5.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-editors/featherpad/Manifest b/app-editors/featherpad/Manifest
index 5cc369b92d37..799914a36ec3 100644
--- a/app-editors/featherpad/Manifest
+++ b/app-editors/featherpad/Manifest
@@ -1 +1,2 @@
DIST featherpad-1.5.0.tar.gz 1087068 BLAKE2B aef468f426c9c635624fe16f8180647a9f62a12c98d654dfb340758ff524e629341469ec3f37cfe8a481def99ba6c99672aa31c49b03226e2e895dce11e9b5e6 SHA512 984d1fba0e4bcb1eda8c2dd3bee34cf2ee0ba5604dd2c9328cc67531099b8a806e8ab79020510049eb788764cf0ad4486c128eefb43d9ab1ccdc4a3c06c48497
+DIST featherpad-1.5.1.tar.gz 1087189 BLAKE2B ede7cde803f5133ccab847c1fd1279de97b4cc3ad3e56874f26096e2cbf17dd197a3db1e6ff8b41c603501d541e314ea9ff434c0be486abd42ce4c9ec1555e56 SHA512 2fff60896c30402ffc87a8daecd6b80d86ff1b19dcc3946d507c8f37742b033cad60fbcb7df61e7e4cbb53821c0d06b5b732a5728cbbb6af3ea03b5872075ea3
diff --git a/app-editors/featherpad/featherpad-1.5.1.ebuild b/app-editors/featherpad/featherpad-1.5.1.ebuild
new file mode 100644
index 000000000000..9b69e0fe90b1
--- /dev/null
+++ b/app-editors/featherpad/featherpad-1.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
+HOMEPAGE="https://github.com/tsujan/FeatherPad"
+SRC_URI="https://github.com/tsujan/FeatherPad/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FeatherPad-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+X"
+
+RDEPEND="
+ app-text/hunspell:=
+ dev-qt/qtbase:6[dbus,gui,widgets]
+ dev-qt/qtsvg:6
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="dev-qt/qttools:6[linguist]"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITHOUT_X11=$(usex !X)
+ )
+ cmake_src_configure
+}