summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-07-09 22:22:29 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-07-09 22:22:29 +0900
commit0ae1e3f61e2bbb3fb4b5757608271bc6f72be986 (patch)
tree8462937287524dd4f54ea5f7376fad3b591349c9 /app-editors
parentapp-editors/aee: update HOMEPAGE and SRC_URI (diff)
downloadgentoo-0ae1e3f61e2bbb3fb4b5757608271bc6f72be986.tar.gz
gentoo-0ae1e3f61e2bbb3fb4b5757608271bc6f72be986.tar.bz2
gentoo-0ae1e3f61e2bbb3fb4b5757608271bc6f72be986.zip
app-editors/aee: update to EAPI 6
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/aee/aee-2.2.15b.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/app-editors/aee/aee-2.2.15b.ebuild b/app-editors/aee/aee-2.2.15b.ebuild
index 7d50170e51ae..3610053fa695 100644
--- a/app-editors/aee/aee-2.2.15b.ebuild
+++ b/app-editors/aee/aee-2.2.15b.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI="6"
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="An easy to use text editor"
#HOMEPAGE="http://mahon.cwx.net/ http://www.users.uswest.net/~hmahon/"
@@ -18,36 +18,37 @@ IUSE="X"
RDEPEND="X? ( x11-libs/libX11 )"
DEPEND="${RDEPEND}"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-ae-location.patch
+PATCHES=( "${FILESDIR}"/${P}-ae-location.patch )
+DOCS=( Changes README.${PN} ${PN}.i18n.guide ${PN}.msg )
+src_prepare() {
sed -i \
-e "s/make -/\$(MAKE) -/g" \
-e "/^buildaee/s/$/ localaee/" \
-e "/^buildxae/s/$/ localxae/" \
- Makefile || die
+ Makefile
sed -i \
-e "s/\([\t ]\)cc /\1\\\\\$(CC) /" \
-e "/CFLAGS =/s/\" >/ \\\\\$(LDFLAGS)\" >/" \
-e "/other_cflag/s/ \${strip_option}//" \
- create.mk.{aee,xae} || die
+ create.mk.{aee,xae}
- tc-export CC
+ default
}
src_compile() {
local target="aee"
use X && target="both"
- emake ${target}
+ emake CC="$(tc-getCC)" ${target}
}
src_install() {
dobin ${PN}
dosym ${PN} /usr/bin/rae
doman ${PN}.1
- dodoc Changes README.${PN} ${PN}.i18n.guide ${PN}.msg
+ einstalldocs
insinto /usr/share/${PN}
doins help.ae