summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Reifschneider <tranquility@gentoo.org>2016-08-22 22:37:42 +0200
committerOle Reifschneider <tranquility@gentoo.org>2016-08-22 22:42:07 +0200
commit1e1a9138936b12e381249657527f517d9e91a027 (patch)
tree9de6ec07a2781c4c253d41268a324c201f2ab293 /app-editors
parentdev-ruby/neovim-ruby-client: Initial commit (diff)
downloadgentoo-1e1a9138936b12e381249657527f517d9e91a027.tar.gz
gentoo-1e1a9138936b12e381249657527f517d9e91a027.tar.bz2
gentoo-1e1a9138936b12e381249657527f517d9e91a027.zip
app-editors/neovim: Bump to 0.1.5
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/neovim/Manifest1
-rw-r--r--app-editors/neovim/neovim-0.1.5.ebuild77
-rw-r--r--app-editors/neovim/neovim-9999.ebuild6
3 files changed, 82 insertions, 2 deletions
diff --git a/app-editors/neovim/Manifest b/app-editors/neovim/Manifest
index 2b86755b8911..edd6bd97a15f 100644
--- a/app-editors/neovim/Manifest
+++ b/app-editors/neovim/Manifest
@@ -3,3 +3,4 @@ DIST neovim-0.1.1.tar.gz 7584560 SHA256 f39bcab23457c66ce0d67dcf8029743703f86041
DIST neovim-0.1.2.tar.gz 7610804 SHA256 549881465eff82454660ae92d857d6ffa22383d45c94c46f3753fd1b0e699247 SHA512 dc03d92ff296f3ff55225d514479f1ac201a5a65eb8a6c02e71935ca44feb8ab15897b26a2ea46e53771f902c57b027d07e02f95673268ee060c6b77c4aa90e4 WHIRLPOOL ef1253249120c89c6efc15520263c889a9972df0c11e9353dedeee112c46ee9b92355fa3dabdf2d15cb7d0416681d1c8b55a9c02266048154f3afe104fdf4ff9
DIST neovim-0.1.3.tar.gz 7636777 SHA256 7a86892d941b8829537ad46864b9a363d009ba56aeefdef2ee15ffa3eee5f92b SHA512 70c979fa06784cae4ded43c7fef7906c743729ed43a50003deec1d2ab7a800bfeab81c394893796a06d0f37811867062b2f766936c2a871f7d968b350729d4c8 WHIRLPOOL 1b3ccb589b3b2ee6d0e6bb1e2139c6ae508859637a0b075a6ccef5168386737713549abab37c7148d9d44d19be54a75587253144aaa1b4c5315408838cdaa4c5
DIST neovim-0.1.4.tar.gz 7678847 SHA256 bb7e359eb83db20c5ec5984b470b249372b6dcd813ae2ccf72c01cce560f93e9 SHA512 e96e768703e4b842355a7543e5c9980b148b9b10cd032570fb420e3e1207102f9769fa6d36fba1d263ed9333d339eab387a196d4a8f724d89db2800097b89d37 WHIRLPOOL 6512b91931168c64fc34f626aeb409c8dc9612e00389a86c7fc07232fd8d26bd289d87dbbf8f01ac9297aa48c33682dc129ab936d0b24aee3c38627e863cc9e6
+DIST neovim-0.1.5.tar.gz 7813974 SHA256 f286ff7994ef1835272285425d65804063f112c91925fee3ef8865282a6d2b7e SHA512 3332b151d23b4f2b133b8f30f4af41686f7092cebbc7ab402b742be7b302bb6acbe9a01c2f475caad8d14a78dd3570109a5c447ab31f0b65ebf442631a31c6f9 WHIRLPOOL be7cd42978385c62af21cf06a48650e361454ff1c79aa783ed7a221e82d73bf3437a9876c9635f27639e3953fdfbe3ecb6958780341d0fbc80fb465ce50cdf29
diff --git a/app-editors/neovim/neovim-0.1.5.ebuild b/app-editors/neovim/neovim-0.1.5.ebuild
new file mode 100644
index 000000000000..f23db6ef499e
--- /dev/null
+++ b/app-editors/neovim/neovim-0.1.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Vim-fork focused on extensibility and agility."
+HOMEPAGE="https://neovim.io"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/neovim/neovim.git"
+else
+ SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0 vim"
+SLOT="0"
+IUSE="+nvimpager perl python ruby +jemalloc"
+
+CDEPEND="dev-lang/luajit:2
+ >=dev-libs/libtermkey-0.17
+ >=dev-libs/libuv-1.2.0
+ >=dev-libs/msgpack-1.0.0
+ >=dev-libs/unibilium-1.1.1
+ dev-libs/libvterm
+ dev-lua/lpeg[luajit]
+ dev-lua/mpack[luajit]
+ jemalloc? ( dev-libs/jemalloc )
+"
+DEPEND="${CDEPEND}
+ virtual/libiconv
+ virtual/libintl"
+RDEPEND="${CDEPEND}
+ perl? ( dev-lang/perl )
+ python? ( dev-python/neovim-python-client )
+ ruby? ( dev-ruby/neovim-ruby-client )
+"
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+src_prepare() {
+ # use our system vim dir
+ sed -e '/^# define SYS_VIMRC_FILE/s|$VIM|'"${EPREFIX}"'/etc/vim|' \
+ -i src/nvim/globals.h || die
+
+ # add eclass to bash filetypes
+ sed -e 's|*.ebuild|*.ebuild,*.eclass|' -i runtime/filetype.vim || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ export USE_BUNDLED_DEPS=OFF
+ append-cflags "-Wno-error"
+ local mycmakeargs=(
+ $(cmake-utils_use_enable jemalloc JEMALLOC)
+ -DLIBUNIBILIUM_USE_STATIC=OFF
+ -DLIBTERMKEY_USE_STATIC=OFF
+ -DLIBVTERM_USE_STATIC=OFF
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # install a default configuration file
+ insinto /etc/vim
+ doins "${FILESDIR}"/sysinit.vim
+
+ # conditionally install a symlink for nvimpager
+ if use nvimpager; then
+ dosym /usr/share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
+ fi
+}
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index a9c90de93814..f23db6ef499e 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -17,7 +17,7 @@ fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="+nvimpager perl python +jemalloc"
+IUSE="+nvimpager perl python ruby +jemalloc"
CDEPEND="dev-lang/luajit:2
>=dev-libs/libtermkey-0.17
@@ -34,7 +34,9 @@ DEPEND="${CDEPEND}
virtual/libintl"
RDEPEND="${CDEPEND}
perl? ( dev-lang/perl )
- python? ( dev-python/neovim-python-client )"
+ python? ( dev-python/neovim-python-client )
+ ruby? ( dev-ruby/neovim-ruby-client )
+"
CMAKE_BUILD_TYPE=RelWithDebInfo