summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-03-17 22:36:00 -0400
committerMatt Turner <mattst88@gentoo.org>2023-03-17 22:36:00 -0400
commit234aa30bb65a076ab6801755da50d93e13539e90 (patch)
tree275a0987ae531c9656b857572d93edee556a926e /app-editors
parentnet-libs/libsoup: Version bump to 3.4.0 (diff)
downloadgentoo-234aa30bb65a076ab6801755da50d93e13539e90.tar.gz
gentoo-234aa30bb65a076ab6801755da50d93e13539e90.tar.bz2
gentoo-234aa30bb65a076ab6801755da50d93e13539e90.zip
app-editors/gnome-text-editor: Version bump to 44.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gnome-text-editor/Manifest1
-rw-r--r--app-editors/gnome-text-editor/gnome-text-editor-44.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-editors/gnome-text-editor/Manifest b/app-editors/gnome-text-editor/Manifest
index 1ee221f952c3..7235392331ff 100644
--- a/app-editors/gnome-text-editor/Manifest
+++ b/app-editors/gnome-text-editor/Manifest
@@ -1,2 +1,3 @@
DIST gnome-text-editor-43.2.tar.xz 611536 BLAKE2B d2230dee0b858384af9c9138631262eca27c0d79d9fc9dbf0a19206e325691326c1a8f80dee5ee4ade6f023b2cf91f10425eb522beed72bc41768645ca8200bc SHA512 b5fd2b5605b6ded13f0bcb684e543f8cd5fae0ec28f713d5cb45e07e5e17115632595d83e2ecbb37b7fba2eec887c11da2ea8d17b842de75ce1c4e27a0f17187
+DIST gnome-text-editor-44.0.tar.xz 610996 BLAKE2B 02ab81055402df584a448d0e611b608e5fa10d6f4a600755cbab9f730aa1806268f7277dafb4fd3aa95ff2be64d2894806c6038ad81dae7cfb87b28dccc7da24 SHA512 bca373a124c3e648fa28da1a493163d768488fa3645fcfbfa7a115e195c0c971dc98e007c9c0fdf7fe415df64e76071fc83e33831707bb31154e66355948bbb3
DIST gnome-text-editor-44.rc.tar.xz 608816 BLAKE2B 6712bb75d1a02c5544736fb9d4e9aba6a9fffff9c8ffc1f9ac89359e911184b27dd0d3716c54c8583aa13ab66ef9c2ca36dc374c2285b263df58bace6e6ecdc9 SHA512 d704b32f6c83493cf17ea4afa7720ebd346f3667e780a1ed01425b8246930c23f2e078c8bc62ca65e00598d316da71da8baf057f2e13977dfd4789005e2a0b73
diff --git a/app-editors/gnome-text-editor/gnome-text-editor-44.0.ebuild b/app-editors/gnome-text-editor/gnome-text-editor-44.0.ebuild
new file mode 100644
index 000000000000..a65ff8c7c29b
--- /dev/null
+++ b/app-editors/gnome-text-editor/gnome-text-editor-44.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A simple text editor for the GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-text-editor"
+S="${WORKDIR}/gnome-text-editor-${PV/_/.}"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="spell"
+
+KEYWORDS="~amd64 ~riscv"
+
+DEPEND="
+ >=dev-libs/glib-2.73.0:2
+ >=gui-libs/gtk-4.7:4
+ >=gui-libs/gtksourceview-5.5.0:5
+ >=gui-libs/libadwaita-1.2:1
+ app-text/editorconfig-core-c
+ x11-libs/cairo
+ spell? (
+ >=app-text/enchant-2.2.0:2
+ dev-libs/icu:=
+ )
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.21
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature spell enchant)
+ -Dbugreport_url="https://bugs.gentoo.org"
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}