summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-06 21:08:22 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-06 21:41:58 -0700
commit5af4d07b53507b8ab36970f2d5f2c1941656b758 (patch)
treeff5dfe0dacead44bd1eae15f025c9bad64b15998 /app-editors
parentnet-analyzer/gnome-nettool: use ${EPYTHON}, not python3 (diff)
downloadgentoo-5af4d07b53507b8ab36970f2d5f2c1941656b758.tar.gz
gentoo-5af4d07b53507b8ab36970f2d5f2c1941656b758.tar.bz2
gentoo-5af4d07b53507b8ab36970f2d5f2c1941656b758.zip
app-editors/ghex: Version bump to 42.0
Closes: https://bugs.gentoo.org/689922 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/ghex/Manifest1
-rw-r--r--app-editors/ghex/ghex-42.0.ebuild59
-rw-r--r--app-editors/ghex/ghex-9999.ebuild31
3 files changed, 81 insertions, 10 deletions
diff --git a/app-editors/ghex/Manifest b/app-editors/ghex/Manifest
index da21afe0f03f..cf2a16887247 100644
--- a/app-editors/ghex/Manifest
+++ b/app-editors/ghex/Manifest
@@ -1,2 +1,3 @@
DIST ghex-3.41.1.tar.xz 1499804 BLAKE2B dd75dc1cc5d847ae3b932ed0bb98b8e15f44943f76f0ba9f053c6770d05e31d211c9f75a910c93c09cf2de143db8fa0eda4fdb876a0ea3ed0534650e7ac36a65 SHA512 5eccf81c41f5ae56bfe5eab0fb843db0095c75080e7dfc0b19a4c71f40f89931e1cbcd2c58744a6b249d16e2a2e4f96513aaac4c41f46d3b5ae8b2bc851851a0
DIST ghex-4.alpha.1.tar.gz 2165701 BLAKE2B f98758b657f2cc73913bb205439d265e8d8168c91080ca0e064decf277a7e300d9eb82a869951f846a66b5155016f69b0935b2877d24a0482a6b003a821adac2 SHA512 6e7e8d8ff0b981f14f48ed16d3b31ce51a0fb4c978c525cc9f3b2c06114bc1cfaf42e71ea98f1b0d33940a2f6b15a5e053228484259bdc4525bb18f2835b97c8
+DIST ghex-42.0.tar.xz 1007772 BLAKE2B db85755e22470f345fcd926e26addcb3ea71c90bc0d71fb5f02ad71e875b3b0100856e4365f950a4040f266c1826be992e6a7a23e32ddebbf9ccdfce88e45f46 SHA512 20eb8b876e65e3a63b2bf5bcb7258f4c196380395805e7aa374a4dba79e8e0356507b7dad660cdfd49490cb9832863e84dfcfa74dd680f05d34742a3c23f6108
diff --git a/app-editors/ghex/ghex-42.0.ebuild b/app-editors/ghex/ghex-42.0.ebuild
new file mode 100644
index 000000000000..5c851aeff170
--- /dev/null
+++ b/app-editors/ghex/ghex-42.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="GNOME hexadecimal editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Ghex"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2+ FDL-1.1+"
+IUSE="gtk-doc test"
+RESTRICT="!test? ( test )"
+SLOT="4"
+
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ >=gui-libs/gtk-4.0.0:4
+ dev-libs/gobject-introspection
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( dev-util/gi-docgen )
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+ dev-util/gtk-update-icon-cache
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/gtk-doc/
+ -Dintrospection=enabled
+ $(meson_use gtk-doc gtk_doc)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-editors/ghex/ghex-9999.ebuild b/app-editors/ghex/ghex-9999.ebuild
index 02e8fb9d1908..5c851aeff170 100644
--- a/app-editors/ghex/ghex-9999.ebuild
+++ b/app-editors/ghex/ghex-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,30 +13,41 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
SRC_URI=""
else
- MY_PV="4.alpha.1"
- SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${MY_PV}/${PN}-${MY_PV}.tar.gz"
KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
- S="${WORKDIR}/${PN}-${MY_PV}"
fi
LICENSE="GPL-2+ FDL-1.1+"
+IUSE="gtk-doc test"
+RESTRICT="!test? ( test )"
SLOT="4"
RDEPEND="
- >=dev-libs/atk-1.0.0
- >=dev-libs/glib-2.31.10:2
- >=x11-libs/gtk+-3.3.8:3
- gui-libs/gtk:4
+ >=dev-libs/glib-2.66.0:2
+ >=gui-libs/gtk-4.0.0:4
+ dev-libs/gobject-introspection
"
DEPEND="${RDEPEND}"
BDEPEND="
- dev-libs/appstream-glib
- dev-libs/libxml2:2
+ gtk-doc? ( dev-util/gi-docgen )
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+ dev-util/gtk-update-icon-cache
dev-util/itstool
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
"
+src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/gtk-doc/
+ -Dintrospection=enabled
+ $(meson_use gtk-doc gtk_doc)
+ )
+ meson_src_configure
+}
+
pkg_postinst() {
xdg_pkg_postinst
gnome2_schemas_update