summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-02-09 09:18:20 +0100
committerUlrich Müller <ulm@gentoo.org>2017-02-10 00:13:23 +0100
commit5f6e98babee9b1db6b8400411e189989c0532878 (patch)
tree46c81fbce5b84af1c160e4a672833aa8d5ab8c23 /app-editors
parentmedia-gfx/gscan2pdf: New package (diff)
downloadgentoo-5f6e98babee9b1db6b8400411e189989c0532878.tar.gz
gentoo-5f6e98babee9b1db6b8400411e189989c0532878.tar.bz2
gentoo-5f6e98babee9b1db6b8400411e189989c0532878.zip
app-editors/emacs: Add dynamic-loading USE flag.
This will enable loading of dynamic libraries at runtime. Based on patch submitted by Steven Cordwell <steven.cordwell@uqconnect.edu.au>. Bug: 608382 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/emacs-25.1.ebuild3
-rw-r--r--app-editors/emacs/emacs-25.2_rc1.ebuild3
-rw-r--r--app-editors/emacs/metadata.xml2
3 files changed, 6 insertions, 2 deletions
diff --git a/app-editors/emacs/emacs-25.1.ebuild b/app-editors/emacs/emacs-25.1.ebuild
index ad64c61bb6c9..b18f6a40c242 100644
--- a/app-editors/emacs/emacs-25.1.ebuild
+++ b/app-editors/emacs/emacs-25.1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://gnu/emacs/${P}.tar.xz"
LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
SLOT="25"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="acl alsa aqua athena cairo dbus games gconf gfile gif gpm gsettings gtk +gtk3 gzip-el hesiod imagemagick +inotify jpeg kerberos libxml2 livecd m17n-lib motif pax_kernel png selinux sound source ssl svg tiff toolkit-scroll-bars wide-int X Xaw3d xft +xpm xwidgets zlib"
+IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif gpm gsettings gtk +gtk3 gzip-el hesiod imagemagick +inotify jpeg kerberos libxml2 livecd m17n-lib motif pax_kernel png selinux sound source ssl svg tiff toolkit-scroll-bars wide-int X Xaw3d xft +xpm xwidgets zlib"
REQUIRED_USE="?? ( aqua X )"
RDEPEND="sys-libs/ncurses:0=
@@ -212,6 +212,7 @@ src_configure() {
--with-file-notification=$(usev inotify || usev gfile || echo no) \
$(use_enable acl) \
$(use_with dbus) \
+ $(use_with dynamic-loading modules) \
$(use_with gpm) \
$(use_with hesiod) \
$(use_with kerberos) $(use_with kerberos kerberos5) \
diff --git a/app-editors/emacs/emacs-25.2_rc1.ebuild b/app-editors/emacs/emacs-25.2_rc1.ebuild
index 33cf9c6a7cb5..0c20a64e9b30 100644
--- a/app-editors/emacs/emacs-25.2_rc1.ebuild
+++ b/app-editors/emacs/emacs-25.2_rc1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://gnu-alpha/emacs/pretest/emacs-${PV/_/-}.tar.xz"
LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
SLOT="25"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="acl alsa aqua athena cairo dbus games gconf gfile gif gpm gsettings gtk +gtk3 gzip-el hesiod imagemagick +inotify jpeg kerberos libxml2 livecd m17n-lib motif pax_kernel png selinux sound source ssl svg tiff toolkit-scroll-bars wide-int X Xaw3d xft +xpm xwidgets zlib"
+IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif gpm gsettings gtk +gtk3 gzip-el hesiod imagemagick +inotify jpeg kerberos libxml2 livecd m17n-lib motif pax_kernel png selinux sound source ssl svg tiff toolkit-scroll-bars wide-int X Xaw3d xft +xpm xwidgets zlib"
REQUIRED_USE="?? ( aqua X )"
RDEPEND="sys-libs/ncurses:0=
@@ -212,6 +212,7 @@ src_configure() {
--with-file-notification=$(usev inotify || usev gfile || echo no) \
$(use_enable acl) \
$(use_with dbus) \
+ $(use_with dynamic-loading modules) \
$(use_with gpm) \
$(use_with hesiod) \
$(use_with kerberos) $(use_with kerberos kerberos5) \
diff --git a/app-editors/emacs/metadata.xml b/app-editors/emacs/metadata.xml
index a42a18a961cf..61b88217833d 100644
--- a/app-editors/emacs/metadata.xml
+++ b/app-editors/emacs/metadata.xml
@@ -22,6 +22,8 @@
<use>
<flag name="athena">Enable the MIT Athena widget set
(<pkg>x11-libs/libXaw</pkg>)</flag>
+ <flag name="dynamic-loading">Enable loading of dynamic libraries at
+ runtime</flag>
<flag name="games">Support shared score files for games</flag>
<flag name="gconf">Use <pkg>gnome-base/gconf</pkg> to read the system
font name</flag>