summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-04-08 09:46:15 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-04-08 09:47:01 +0200
commit759e20f0d5fb63f0911e0e59a8fbfa43a0606884 (patch)
tree204a4e4e5c9cd7ec09c02d1ae5b0d2915fbe4e5b /app-editors
parentsys-devel/gdb: use ${CHOST}-pkg-config, bug #716558 (diff)
downloadgentoo-759e20f0d5fb63f0911e0e59a8fbfa43a0606884.tar.gz
gentoo-759e20f0d5fb63f0911e0e59a8fbfa43a0606884.tar.bz2
gentoo-759e20f0d5fb63f0911e0e59a8fbfa43a0606884.zip
app-editors/nano: Bump to version 4.9.2
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/Manifest1
-rw-r--r--app-editors/nano/nano-4.9.2.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index 5a34202719b6..b80202e17b61 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -1,3 +1,4 @@
DIST nano-4.6.tar.gz 2970798 BLAKE2B d6dfc702d374d1cbcd61080c8e0082b7931dc8c593c97eb705d878d25487a78dc1ebcb8004f742f5ecc3af1b5a31abcf6577e87aba96fb95d16029ff55e7af58 SHA512 76fb43495ca1f88ee8864eee5d023b6cd86bc35fba00151b4c6af53ae06e6b3828379e7d52a16c7df0956e9e04602a86ff8e8a7c1997320507ca041195bf004b
DIST nano-4.9.1.tar.gz 2995183 BLAKE2B a5e455d94e683bd3ae00c37bd4395465ded281e1cbf434a0035b2d816b53b6d24f3fc966c44c8da643122dc2920f8ddefb0d37574baafe947dd107e1ede7034d SHA512 155622092ee5a99dab30a6acd5cf35ecf087476aa48eabcdf7e1259af098483f84eef7569380fe7c47d4d69f63e61af10a3cc5c29c45f1242c17366c0f15835b
+DIST nano-4.9.2.tar.gz 2996106 BLAKE2B f3de611022f72de050f96b254a10fb9587014e4e239e34024d1941f9bd5d6abef17dbd1da95bba7cd328237137be1c79421ef7423cf40bab6a5577f9ae8ba587 SHA512 bbb43b63e03d104f168394c00778b5674249285c2400bb4664738a5badc7e5320b5a96f6b0275aa4e6f34f8127830564e87a8658442e358e5261116c595155b6
DIST nano-4.9.tar.gz 3000427 BLAKE2B 37ed08fa6b902951687ef26a527e1a0da3199946c73bed5d9fd0464a76af643b55a0900e7c1a1237af31867a7231f1b383dad423e780408560fa8246b18e30a4 SHA512 abce064a5cb55f730e41a7a8fbd8b2f9626fc6834b30cd05d62fe73b7f284d8cd80f44c6b84bb5370b980f00d3a71cf8c33408628229c2ee3b8a1670fa5e953c
diff --git a/app-editors/nano/nano-4.9.2.ebuild b/app-editors/nano/nano-4.9.2.ebuild
new file mode 100644
index 000000000000..e27dda0e78d7
--- /dev/null
+++ b/app-editors/nano/nano-4.9.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.sv.gnu.org/nano.git"
+ inherit git-r3 autotools
+else
+ MY_P="${PN}-${PV/_}"
+ SRC_URI="https://www.nano-editor.org/dist/v${PV:0:1}/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug justify +magic minimal ncurses nls slang +spell +split-usr static unicode"
+
+LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
+ sys-libs/ncurses:0=[static-libs(+)]
+ magic? ( sys-apps/file[static-libs(+)] )
+ nls? ( virtual/libintl )
+ !ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+src_prepare() {
+ default
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ local myconf=(
+ --bindir="${EPREFIX}"/bin
+ --htmldir=/trash
+ $(use_enable !minimal color)
+ $(use_enable !minimal multibuffer)
+ $(use_enable !minimal nanorc)
+ $(use_enable magic libmagic)
+ $(use_enable spell speller)
+ $(use_enable justify)
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable unicode utf8)
+ $(use_enable minimal tiny)
+ $(usex ncurses --without-slang $(use_with slang))
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ # don't use "${ED}" here or things break (#654534)
+ rm -r "${D}"/trash || die
+
+ dodoc doc/sample.nanorc
+ docinto html
+ dodoc doc/faq.html
+ insinto /etc
+ newins doc/sample.nanorc nanorc
+ if ! use minimal ; then
+ # Enable colorization by default.
+ sed -i \
+ -e '/^# include /s:# *::' \
+ "${ED}"/etc/nanorc || die
+ fi
+
+ use split-usr && dosym ../../bin/nano /usr/bin/nano
+}