summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-12-11 00:42:43 +0100
committerUlrich Müller <ulm@gentoo.org>2017-12-11 00:56:49 +0100
commit7b54f926721074aced28664f5d8080dbc3a1d674 (patch)
tree55584e67d33bb12cfe843af7b624a64ae0c5445c /app-editors
parentsys-apps/iproute2: 4.14.1-r1 stable on ppc and ppc64, bug #639536 (diff)
downloadgentoo-7b54f926721074aced28664f5d8080dbc3a1d674.tar.gz
gentoo-7b54f926721074aced28664f5d8080dbc3a1d674.tar.bz2
gentoo-7b54f926721074aced28664f5d8080dbc3a1d674.zip
app-editors/emacs: Fix build failure with 17.0 profiles.
The following comment from upstream is in configure.ac of emacs-25.3: "-no-pie or -nopie fixes a temacs segfault on Gentoo, OpenBSD, Ubuntu, and other systems with "hardened" GCC configurations for some reason (Bug#18784). We don't know why this works, but not segfaulting is better than segfaulting." Adding -no-pie to 23.4 and 24.5 appears to make them build, too. Note that only append-ldflags fixes the build failure, while append-flags does not (at least not for 23.4). Thanks to Mats Lidell for pointing me to the above upstream comment. Closes: https://bugs.gentoo.org/639568 Closes: https://bugs.gentoo.org/639570 Package-Manager: Portage-2.3.17, Repoman-2.3.6
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/emacs-23.4-r16.ebuild1
-rw-r--r--app-editors/emacs/emacs-24.5-r4.ebuild1
2 files changed, 2 insertions, 0 deletions
diff --git a/app-editors/emacs/emacs-23.4-r16.ebuild b/app-editors/emacs/emacs-23.4-r16.ebuild
index 210f81f16181..230f36053ce5 100644
--- a/app-editors/emacs/emacs-23.4-r16.ebuild
+++ b/app-editors/emacs/emacs-23.4-r16.ebuild
@@ -104,6 +104,7 @@ src_configure() {
strip-flags
filter-flags -fstrict-aliasing -pie
append-flags $(test-flags -fno-strict-aliasing)
+ append-ldflags $(test-flags -no-pie) #639568
if use sh; then
replace-flags "-O[1-9]" -O0 #262359
diff --git a/app-editors/emacs/emacs-24.5-r4.ebuild b/app-editors/emacs/emacs-24.5-r4.ebuild
index 12bb3ccaf3b7..1dd73ddaf8c0 100644
--- a/app-editors/emacs/emacs-24.5-r4.ebuild
+++ b/app-editors/emacs/emacs-24.5-r4.ebuild
@@ -97,6 +97,7 @@ src_prepare() {
src_configure() {
strip-flags
filter-flags -pie #526948
+ append-ldflags $(test-flags -no-pie) #639570
if use sh; then
replace-flags "-O[1-9]" -O0 #262359