summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErvin Peters <ervin.peters@ervnet.de>2016-05-03 20:53:44 +1000
committerSam Jorna <wraeth@gentoo.org>2016-05-03 20:54:46 +1000
commit88d0ed8b93254c34bbc3cda51b666f5f7a75a2ab (patch)
tree6f47132b0224f5c752754d7072b14ac6fd4d0a40 /app-editors
parentapp-admin/tripwire: Bump to version 2.4.3.1. (diff)
downloadgentoo-88d0ed8b93254c34bbc3cda51b666f5f7a75a2ab.tar.gz
gentoo-88d0ed8b93254c34bbc3cda51b666f5f7a75a2ab.tar.bz2
gentoo-88d0ed8b93254c34bbc3cda51b666f5f7a75a2ab.zip
app-editors/scite: bump to 3.6.5
Version bump to 3.6.5, bump to EAPI6, fixes build with ${CC}. Gentoo-bug: 581220 Package-Manager: portage-2.2.28
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/scite/Manifest1
-rw-r--r--app-editors/scite/scite-3.6.5.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-editors/scite/Manifest b/app-editors/scite/Manifest
index 131043ad3942..2a42302ccb3b 100644
--- a/app-editors/scite/Manifest
+++ b/app-editors/scite/Manifest
@@ -1,3 +1,4 @@
DIST scite355.tgz 2302137 SHA256 20515597ac986f1727c97bda2c27d88487ddb79cfe330b0b890b5e25330b7d9f SHA512 cdd9d3aa621f5d31632cfb9f71524255a4b47b70a654bf4bc8a25a76f8a2dbe098a48e0cd4587ced8ca8455be7e809973e212fcbcde5b62087aa0f9528f7f40d WHIRLPOOL c901804481042b859be68f44ab728544e97975d61219a4bb576ba3da00bd663c8877e9b23b981a0295d759cae3e9afd037d981923086c6850ff29f01c43ec9f6
DIST scite362.tgz 2368491 SHA256 6530d0d86c72485b815663e3b2c2987d59779340a71632ed8bb97a43530737a3 SHA512 cb9618e962a16db7484e16a494b3da39f210250277e9772b112af5e16649b38f27ead0ec61664b1211c9263880cb7f3c34b5b32d94a4e70087fb1503805740c1 WHIRLPOOL 52a31f0e1518a9d8f6107aa22eead7da89e1d1ea6523a2aae57fbd7a3a8ecbd192c124c3d2550acea6383457763d6e501b14791ec6490a54379c5d13356e42da
DIST scite364.tgz 2386959 SHA256 6a27a1062b838e0fe914fb045f265935e5d39e34d69ae894b55f971437192baa SHA512 eaba353edac23902a8f446fb8877f3e5dd43221e5289bc38941d76068a3f7c87602e9eb5828e6caafec56657d05b5268aad2a1bb36356a14154de3c22602c76d WHIRLPOOL f1b4c64eb4a5c6d6e73ffb3f457a5b5ddf8d31cf5f5778b204c05a093bcfb8e78e7a8cab634cf369ce29f200c11b933492f01c30afb268f581d465ed31157c88
+DIST scite365.tgz 2391190 SHA256 dde62ebebbd4c36afd81ab0e745ff04839f4cfc911496f2d0463aade1374b9d1 SHA512 193dcb1f8787a7c7d520ce62462e5c95e7b6bcaf79f4ab23f9885474fb0444dbc5a69a0d45eafc592e5fff2a2e746a9aba599799e847e3c74d3436eed26580a9 WHIRLPOOL e79a2f05444c16f40f6c84fd252d3b71247a48f6af27f912d3f51de99b968c93ec505bc903aa4df407d1ff503f3ce35052004c46e3f7fe8502d0d0ef4939610e
diff --git a/app-editors/scite/scite-3.6.5.ebuild b/app-editors/scite/scite-3.6.5.ebuild
new file mode 100644
index 000000000000..f3aeac37a08b
--- /dev/null
+++ b/app-editors/scite/scite-3.6.5.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit toolchain-funcs eutils
+
+MY_PV=${PV//./}
+DESCRIPTION="A very powerful editor for programmers"
+HOMEPAGE="http://www.scintilla.org/SciTE.html"
+SRC_URI="mirror://sourceforge/scintilla/${PN}${MY_PV}.tgz"
+
+LICENSE="HPND lua? ( MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="lua"
+
+RDEPEND="dev-libs/glib:=
+ x11-libs/cairo:*
+ x11-libs/gtk+:2
+ x11-libs/gdk-pixbuf:*
+ x11-libs/pango:*
+ lua? ( >=dev-lang/lua-5:= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}/gtk"
+
+src_prepare() {
+ sed -i "${WORKDIR}/scintilla/gtk/makefile" \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e "s#^CCOMP =\(.*\)#CCOMP = $(tc-getCC)#" \
+ -e "s#-Os##" \
+ || die "error patching /scintilla/gtk/makefile"
+
+ sed -i "${WORKDIR}/scite/gtk/makefile" \
+ -e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
+ || die "error patching /scite/gtk/makefile"
+
+ # repair and enhance the .desktop file
+ sed -i "${WORKDIR}/scite/gtk/SciTE.desktop" \
+ -e "s/^Encoding/#Encoding/" \
+ -e "s#text/plain#text/\*;application/xhtml+xml#" \
+ -e "s#^Categories=\(.*\)#Categories=Development;#" \
+ || die "error patching /scite/gtk/SciTe.desktop"
+
+ sed -i "${S}/makefile" \
+ -e 's#usr/local#usr#g' \
+ -e 's#/gnome/apps/Applications#/applications#' \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e "s#^CCOMP =\(.*\)#CCOMP = $(tc-getCC)#" \
+ -e 's#${D}##' \
+ -e 's#-g root#-g 0#' \
+ -e "s#-Os##" \
+ || die "error patching gtk/makefile"
+
+ eapply_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" \
+ LDFLAGS="$(raw-ldflags)" AR="$(tc-getAR)" \
+ -C "${WORKDIR}/scintilla/gtk"
+
+ if use lua; then
+ emake
+ else
+ emake NO_LUA=1
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/{pixmaps,applications}
+
+ emake DESTDIR="${ED}" install
+
+ # we have to keep this because otherwise it'll break upgrading
+ mv "${ED}/usr/bin/SciTE" "${ED}/usr/bin/scite" || die
+ dosym /usr/bin/scite /usr/bin/SciTE
+
+ doman ../doc/scite.1
+ dodoc ../README
+}