summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-03 18:04:08 -0500
committerAaron Bauman <bman@gentoo.org>2018-04-13 20:49:23 -0400
commit892a2940a80af938c141c1b46975978b5bc1218b (patch)
tree639ecf8a52a33d1d918b6c3f802c00c4962342ac /app-editors
parentdev-libs/ucommon: fix openssl slot and subslot operator (diff)
downloadgentoo-892a2940a80af938c141c1b46975978b5bc1218b.tar.gz
gentoo-892a2940a80af938c141c1b46975978b5bc1218b.tar.bz2
gentoo-892a2940a80af938c141c1b46975978b5bc1218b.zip
app-editors/bluefish: fdo-mime->xdg-utils
Also added gnome2-utils. Package-Manager: Portage-2.3.27, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/7794
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/bluefish/bluefish-2.2.10.ebuild18
-rw-r--r--app-editors/bluefish/bluefish-2.2.6.ebuild18
-rw-r--r--app-editors/bluefish/bluefish-2.2.8.ebuild18
-rw-r--r--app-editors/bluefish/bluefish-2.2.9.ebuild18
4 files changed, 48 insertions, 24 deletions
diff --git a/app-editors/bluefish/bluefish-2.2.10.ebuild b/app-editors/bluefish/bluefish-2.2.10.ebuild
index edf1fbd4866e..83184d2f47e1 100644
--- a/app-editors/bluefish/bluefish-2.2.10.ebuild
+++ b/app-editors/bluefish/bluefish-2.2.10.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit autotools eutils fdo-mime python-single-r1
+inherit autotools eutils gnome2-utils python-single-r1 xdg-utils
MY_P=${P/_/-}
@@ -80,9 +80,14 @@ src_install() {
prune_libtool_files
}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
einfo "Adding XML catalog entries..."
/usr/bin/xmlcatalog --noout \
@@ -94,8 +99,9 @@ pkg_postinst() {
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
einfo "Removing XML catalog entries..."
/usr/bin/xmlcatalog --noout \
--del 'Bluefish/DTD/Bflang' \
diff --git a/app-editors/bluefish/bluefish-2.2.6.ebuild b/app-editors/bluefish/bluefish-2.2.6.ebuild
index 2c420dafef14..ff25f887a720 100644
--- a/app-editors/bluefish/bluefish-2.2.6.ebuild
+++ b/app-editors/bluefish/bluefish-2.2.6.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit eutils fdo-mime python-single-r1
+inherit eutils gnome2-utils python-single-r1 xdg-utils
MY_P=${P/_/-}
@@ -63,9 +63,14 @@ src_install() {
find "${ED}" -name '*.la' -exec rm -f {} +
}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
einfo "Adding XML catalog entries..."
/usr/bin/xmlcatalog --noout \
@@ -77,8 +82,9 @@ pkg_postinst() {
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
einfo "Removing XML catalog entries..."
/usr/bin/xmlcatalog --noout \
--del 'Bluefish/DTD/Bflang' \
diff --git a/app-editors/bluefish/bluefish-2.2.8.ebuild b/app-editors/bluefish/bluefish-2.2.8.ebuild
index bf84c0859b2e..4e07508bb106 100644
--- a/app-editors/bluefish/bluefish-2.2.8.ebuild
+++ b/app-editors/bluefish/bluefish-2.2.8.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit eutils fdo-mime python-single-r1
+inherit eutils gnome2-utils python-single-r1 xdg-utils
MY_P=${P/_/-}
@@ -74,9 +74,14 @@ src_install() {
prune_libtool_files
}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
einfo "Adding XML catalog entries..."
/usr/bin/xmlcatalog --noout \
@@ -88,8 +93,9 @@ pkg_postinst() {
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
einfo "Removing XML catalog entries..."
/usr/bin/xmlcatalog --noout \
--del 'Bluefish/DTD/Bflang' \
diff --git a/app-editors/bluefish/bluefish-2.2.9.ebuild b/app-editors/bluefish/bluefish-2.2.9.ebuild
index edf1fbd4866e..83184d2f47e1 100644
--- a/app-editors/bluefish/bluefish-2.2.9.ebuild
+++ b/app-editors/bluefish/bluefish-2.2.9.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit autotools eutils fdo-mime python-single-r1
+inherit autotools eutils gnome2-utils python-single-r1 xdg-utils
MY_P=${P/_/-}
@@ -80,9 +80,14 @@ src_install() {
prune_libtool_files
}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
einfo "Adding XML catalog entries..."
/usr/bin/xmlcatalog --noout \
@@ -94,8 +99,9 @@ pkg_postinst() {
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
einfo "Removing XML catalog entries..."
/usr/bin/xmlcatalog --noout \
--del 'Bluefish/DTD/Bflang' \