summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-12-09 22:14:35 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-12-09 22:16:22 +0900
commit90eabcfdd4a2a67ba010ac25df66607c218bfa13 (patch)
tree8cd58888b85a5926059a6cb683ddd85027d5ca22 /app-editors
parentapp-admin/puppet: keyworded 4.10.9 for ppc, bug #639472 (diff)
downloadgentoo-90eabcfdd4a2a67ba010ac25df66607c218bfa13.tar.gz
gentoo-90eabcfdd4a2a67ba010ac25df66607c218bfa13.tar.bz2
gentoo-90eabcfdd4a2a67ba010ac25df66607c218bfa13.zip
app-editors/ee: fix build with >=sys-libs/glibc-2.26
Closes: https://bugs.gentoo.org/638502 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/ee/ee-1.5.2.ebuild1
-rw-r--r--app-editors/ee/files/ee-signal.patch11
2 files changed, 12 insertions, 0 deletions
diff --git a/app-editors/ee/ee-1.5.2.ebuild b/app-editors/ee/ee-1.5.2.ebuild
index 0d343a67d9ea..fc1aec479af4 100644
--- a/app-editors/ee/ee-1.5.2.ebuild
+++ b/app-editors/ee/ee-1.5.2.ebuild
@@ -20,6 +20,7 @@ S="${WORKDIR}/easyedit-${PV}"
PATCHES=(
"${FILESDIR}"/${PN}-init-location.patch
+ "${FILESDIR}"/${PN}-signal.patch
"${FILESDIR}"/${PN}-Wformat-security.patch
)
DOCS=( Changes README.${PN} ${PN}.i18n.guide ${PN}.msg )
diff --git a/app-editors/ee/files/ee-signal.patch b/app-editors/ee/files/ee-signal.patch
new file mode 100644
index 000000000000..41cfa4013068
--- /dev/null
+++ b/app-editors/ee/files/ee-signal.patch
@@ -0,0 +1,11 @@
+--- a/ee.c
++++ b/ee.c
+@@ -552,7 +552,7 @@
+ {
+ int counter;
+
+- for (counter = 1; counter < SIGUNUSED; counter++)
++ for (counter = 1; counter < SIGSYS; counter++)
+ signal(counter, SIG_IGN);
+
+ signal(SIGCHLD, SIG_DFL);