summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOskari Pirhonen <xxc3ncoredxx@gmail.com>2023-03-03 00:46:42 -0600
committerSam James <sam@gentoo.org>2023-03-04 07:18:08 +0000
commit9726595239c9c464b1b8cd9e052beb7bfa5d8add (patch)
treef440faa0a0fa84f06cf092840f706664c082a834 /app-editors
parentapp-editors/retext: enable py3.11 (9999) (diff)
downloadgentoo-9726595239c9c464b1b8cd9e052beb7bfa5d8add.tar.gz
gentoo-9726595239c9c464b1b8cd9e052beb7bfa5d8add.tar.bz2
gentoo-9726595239c9c464b1b8cd9e052beb7bfa5d8add.zip
app-editors/gvim: configure implicit function declarations
Ignore implicit function declarations for platform-specific functions, `acl()` is for Solaris and `statacl()` is for AIX. Closes: https://bugs.gentoo.org/898450 Signed-off-by: Oskari Pirhonen <xxc3ncoredxx@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gvim/gvim-9.0.1000.ebuild8
-rw-r--r--app-editors/gvim/gvim-9.0.1157.ebuild8
-rw-r--r--app-editors/gvim/gvim-9.0.1363.ebuild8
-rw-r--r--app-editors/gvim/gvim-9999.ebuild8
4 files changed, 32 insertions, 0 deletions
diff --git a/app-editors/gvim/gvim-9.0.1000.ebuild b/app-editors/gvim/gvim-9.0.1000.ebuild
index 708d13e40470..5685854ed305 100644
--- a/app-editors/gvim/gvim-9.0.1000.ebuild
+++ b/app-editors/gvim/gvim-9.0.1000.ebuild
@@ -90,6 +90,14 @@ fi
# various failures (bugs #630042 and #682320)
RESTRICT="test"
+# platform-specific checks (bug #898450):
+# - acl() -- Solaris
+# - statacl() -- AIX
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'acl'
+ 'statacl'
+)
+
pkg_setup() {
# people with broken alphabets run into trouble. bug 82186.
unset LANG LC_ALL
diff --git a/app-editors/gvim/gvim-9.0.1157.ebuild b/app-editors/gvim/gvim-9.0.1157.ebuild
index 708d13e40470..5685854ed305 100644
--- a/app-editors/gvim/gvim-9.0.1157.ebuild
+++ b/app-editors/gvim/gvim-9.0.1157.ebuild
@@ -90,6 +90,14 @@ fi
# various failures (bugs #630042 and #682320)
RESTRICT="test"
+# platform-specific checks (bug #898450):
+# - acl() -- Solaris
+# - statacl() -- AIX
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'acl'
+ 'statacl'
+)
+
pkg_setup() {
# people with broken alphabets run into trouble. bug 82186.
unset LANG LC_ALL
diff --git a/app-editors/gvim/gvim-9.0.1363.ebuild b/app-editors/gvim/gvim-9.0.1363.ebuild
index cba104363a07..c6e8ca77a51c 100644
--- a/app-editors/gvim/gvim-9.0.1363.ebuild
+++ b/app-editors/gvim/gvim-9.0.1363.ebuild
@@ -91,6 +91,14 @@ fi
# various failures (bugs #630042 and #682320)
RESTRICT="test"
+# platform-specific checks (bug #898450):
+# - acl() -- Solaris
+# - statacl() -- AIX
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'acl'
+ 'statacl'
+)
+
pkg_setup() {
# people with broken alphabets run into trouble. bug 82186.
unset LANG LC_ALL
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index 01f283c88448..63a3e37a2a0d 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -90,6 +90,14 @@ fi
# various failures (bugs #630042 and #682320)
RESTRICT="test"
+# platform-specific checks (bug #898450):
+# - acl() -- Solaris
+# - statacl() -- AIX
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'acl'
+ 'statacl'
+)
+
pkg_setup() {
# people with broken alphabets run into trouble. bug 82186.
unset LANG LC_ALL