summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-02-25 17:25:03 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-02-25 17:25:24 +1100
commit9a0675d5c7efc81f1d519097b0d98c5557bf1bc2 (patch)
tree877bf7edcee673a04bcc6c7dcc3ae0dddf9610ed /app-editors
parentdev-libs/flatbuffers: remove old (diff)
downloadgentoo-9a0675d5c7efc81f1d519097b0d98c5557bf1bc2.tar.gz
gentoo-9a0675d5c7efc81f1d519097b0d98c5557bf1bc2.tar.bz2
gentoo-9a0675d5c7efc81f1d519097b0d98c5557bf1bc2.zip
app-editors/focuswriter: version bump 1.6.10
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/focuswriter/Manifest1
-rw-r--r--app-editors/focuswriter/focuswriter-1.6.10.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-editors/focuswriter/Manifest b/app-editors/focuswriter/Manifest
index 50c16929e9c3..d8af1a132206 100644
--- a/app-editors/focuswriter/Manifest
+++ b/app-editors/focuswriter/Manifest
@@ -1,3 +1,4 @@
+DIST focuswriter-1.6.10-src.tar.bz2 10202594 BLAKE2B d7b59dc2c37d87ed0d1e58358906a9fef6f14a339e12a50980d17cdbed043f604bb355edca956af61b5fcaa78f68eb35b54ef85fc08dfa00dfa747893d6c1200 SHA512 8c12481af77fa4353840f22a6aa54c5264041afc141d9746e097e42171a9f274663940fc0c5e5e2c91ef677190c682a195cb775199d4b8cc2b1ad040542e2e61
DIST focuswriter-1.6.7-src.tar.bz2 10196583 BLAKE2B 99c749271c785e69f07601575343669ed5be619e646be4ee38cc82242d353a84577842c1ff98f62b0adbbff1a733a0dce82593ac4ffa2eb61e611cea1b2657b5 SHA512 d33c66881b1065aa9812dae14a5fe2a2850ce1c50f4b38e028bcd3f5a4bb1fd489705b0272e3233f3db468b262daefbd906025126f792d04af41722cde2c7bf5
DIST focuswriter-1.6.8-src.tar.bz2 10196595 BLAKE2B 1c726b948469960e1cc35dcf592acf48693035d2792449fdc336ac4bb03029d6d9eaac77c674347ac5e7a1a7ba7cd386de0d4034e7390dd80067b9522d85a08d SHA512 d10a559448f075110d9ba7fec487b9f125a4fcdce7dc1fcd2b21b94613a7d1126baa49623273bf0f56b1b7c2ef026a30c019653ba73e39b6fa78687c862e3402
DIST focuswriter-1.6.9-src.tar.bz2 10202664 BLAKE2B 68525ca548513b9b88ca032c0f629681a592149672611891a1ddfe6a8574a233dfc7bcee64dfcae2255b3dce2cbd15907428f25a7ad27a4ebc5c535d3fb34d7b SHA512 dcebd2e1c16a9eb1d135befef58ba0a276dac8d84385d90db3a8c192f3ff05eb5b6ac11cef239c1c4b4998b396da908ad99d5c89c0eb1438d9eb654f2cc7afec
diff --git a/app-editors/focuswriter/focuswriter-1.6.10.ebuild b/app-editors/focuswriter/focuswriter-1.6.10.ebuild
new file mode 100644
index 000000000000..f61c59e9ba31
--- /dev/null
+++ b/app-editors/focuswriter/focuswriter-1.6.10.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils qmake-utils xdg-utils
+
+DESCRIPTION="A fullscreen and distraction-free word processor"
+HOMEPAGE="https://gottcode.org/focuswriter/"
+SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# drop qtcore subslot when minimal Qt is 5.10
+RDEPEND="
+ app-text/hunspell:=
+ dev-qt/qtcore:5=
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ dev-qt/qtconcurrent:5
+ virtual/pkgconfig
+"
+
+DOCS=( ChangeLog CREDITS NEWS README )
+
+PATCHES=( "${FILESDIR}/${PN}-1.6.0-unbundle-qtsingleapplication.patch" )
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}