summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Tietz <christian.tietz@mailbox.org>2019-11-15 20:39:00 +0100
committerJoonas Niilola <juippis@gentoo.org>2019-11-16 11:45:49 +0200
commitd878b19db4c81766b613c39d54f799846bdda748 (patch)
treef3064aa4835911390f39201c99c85fa2f91e7b98 /app-editors
parentnet-libs/nativebiginteger: remove unused patches (diff)
downloadgentoo-d878b19db4c81766b613c39d54f799846bdda748.tar.gz
gentoo-d878b19db4c81766b613c39d54f799846bdda748.tar.bz2
gentoo-d878b19db4c81766b613c39d54f799846bdda748.zip
app-editors/gummi: Bump to 0.8.0-rc2
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Christian Tietz <christian.tietz@mailbox.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gummi/Manifest1
-rw-r--r--app-editors/gummi/gummi-0.8.0_rc2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-editors/gummi/Manifest b/app-editors/gummi/Manifest
index e8b0584419d5..fe69b8521a11 100644
--- a/app-editors/gummi/Manifest
+++ b/app-editors/gummi/Manifest
@@ -1,2 +1,3 @@
DIST gummi-0.6.6.tar.gz 792642 BLAKE2B 4f6096999b06361811a9149fa08eff5d2315f01e55539c5849c4bc86aab5a482ad9a0adfe84de5d093e66a328b294b4d88e1e2e2f0355bab320f0c094581da97 SHA512 3be94927c9aafa4914ed2b6f6f5022dce5bcca315a1f947fafb8a4c8bbc5a2bc57f07f8ceaaacdd0b92a5a30483ea8b00e570faf62479280d2ad874716e4c47d
DIST gummi-0.7.999.tar.gz 578026 BLAKE2B b3305560d621eab029f0931dfc9978d0883acb886d89d2f9e452a60e465a10736191987523c47fe9f5373d7dd7d112383ebf7eaf030e6f0751197e535e461708 SHA512 1da2171cbb26b8be71c34dd7b1bc025813d35604e465caf67e480c3356a706991e6dcaca3bc99bb862895e4597186850c7d4f203a81a9532a4cd742cd2744dc1
+DIST gummi-0.8.0-rc2.tar.gz 581744 BLAKE2B c0665c8c2f8d6c0b4472ce4b9510362b942b7197ce205be763afe6272c848d4195a31b1cab0515d2d68ed517b153d943d52909744d9c91097d6fbc2a9a2b8793 SHA512 cc50a1d331dd93cca50aa50d2ceeeaa37740631b3cacbfc22d6b0a706bf8d9b00fb0935d1c712534108a3d7b32420e6bebf3f5592cd36a92b290f49b355d22fb
diff --git a/app-editors/gummi/gummi-0.8.0_rc2.ebuild b/app-editors/gummi/gummi-0.8.0_rc2.ebuild
new file mode 100644
index 000000000000..480181fd2a3b
--- /dev/null
+++ b/app-editors/gummi/gummi-0.8.0_rc2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+MY_PV="${PV/_rc/-rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Simple LaTeX editor for GTK+ users"
+HOMEPAGE="https://github.com/alexandervdm/gummi"
+SRC_URI="https://github.com/alexandervdm/${PN}/releases/download/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/gtkspell:3
+ app-text/poppler[cairo]
+ dev-libs/glib:2
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ x11-libs/gtk+:3
+ x11-libs/gtksourceview:3.0
+ x11-libs/pango
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog "Gummi supports spell-checking through gtkspell. Support for"
+ elog "additional languages can be added by installing myspell-**-"
+ elog "packages for your language of choice."
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}