summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-09-05 08:54:19 +0200
committerUlrich Müller <ulm@gentoo.org>2018-09-05 08:54:19 +0200
commite100b17297aee0a24c4f47fc20329a801d7a78df (patch)
treecbd3aa03eb56c3edd30a29d79a4d1637a6f1a84d /app-editors
parentapp-editors/uemacs-pk: Remove old. (diff)
downloadgentoo-e100b17297aee0a24c4f47fc20329a801d7a78df.tar.gz
gentoo-e100b17297aee0a24c4f47fc20329a801d7a78df.tar.bz2
gentoo-e100b17297aee0a24c4f47fc20329a801d7a78df.zip
app-editors/uemacs-pk: Version bump.
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/uemacs-pk/Manifest1
-rw-r--r--app-editors/uemacs-pk/uemacs-pk-4.0.15_p20180719.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-editors/uemacs-pk/Manifest b/app-editors/uemacs-pk/Manifest
index 6c035a94b762..dc21550f5685 100644
--- a/app-editors/uemacs-pk/Manifest
+++ b/app-editors/uemacs-pk/Manifest
@@ -1 +1,2 @@
DIST uemacs-4.0.15_p20180117.tar.xz 151600 BLAKE2B 76a6a3cd3d0abf720721c7c09687c1964958e6c1c05ad8db07e6e561d6714e436d31659d118af85d069ad77da2606b0ac86005824e2ac56db8040a0ea739aabf SHA512 aadf3f9e8ab3f2c9c7bccf305f7a37e75ac1c92c5c388ce35a10b24cedf886f7d9b0ce8b1196c2f96a0d874bd5af130edb3ecb1ccf571d8e8c00753564e38aa7
+DIST uemacs-4.0.15_p20180719.tar.xz 151748 BLAKE2B 66572d3b4eb54310b7468a43fa718faa78aae8070a8675018f8dccc38d2dcb8e93b41942f49ca28b7c8ee5d100b541ecebfa2adc9a84f121a178ade0903029b1 SHA512 0baa273d5f8df75976d01acbe69b2bca7ec803c8a40364ebded39d16874426874af7b7547774c211fbbb96c82fcb69aaf75f8fa5fd3e95422ee105e6be7f9564
diff --git a/app-editors/uemacs-pk/uemacs-pk-4.0.15_p20180719.ebuild b/app-editors/uemacs-pk/uemacs-pk-4.0.15_p20180719.ebuild
new file mode 100644
index 000000000000..0286f0e20430
--- /dev/null
+++ b/app-editors/uemacs-pk/uemacs-pk-4.0.15_p20180719.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="uEmacs/PK is an enhanced version of MicroEMACS"
+HOMEPAGE="https://git.kernel.org/?p=editors/uemacs/uemacs.git;a=summary
+ ftp://ftp.cs.helsinki.fi/pub/Software/Local/uEmacs-PK"
+# snapshot from git repo
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/uemacs-${PV}.tar.xz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/uemacs"
+PATCHES=("${FILESDIR}"/${PN}-4.0.15_p20110825-gentoo.patch)
+
+src_compile() {
+ emake V=1 \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ LIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
+}
+
+src_install() {
+ dobin em
+ insinto /usr/share/${PN}
+ doins emacs.hlp
+ newins emacs.rc .emacsrc
+ dodoc README readme.39e emacs.ps UTF-8-demo.txt
+}