summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2017-11-20 01:50:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-30 00:19:21 +0100
commitecfcfd8e746ba83d767b2af5757bcf9838e4c28b (patch)
tree34d00302cfaebafe84590c34953153f0544a7c4b /app-editors
parentapp-editors/kakoune: update live ebuild (diff)
downloadgentoo-ecfcfd8e746ba83d767b2af5757bcf9838e4c28b.tar.gz
gentoo-ecfcfd8e746ba83d767b2af5757bcf9838e4c28b.tar.bz2
gentoo-ecfcfd8e746ba83d767b2af5757bcf9838e4c28b.zip
app-editors/kakoune: drop old 0_pre20160620
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/kakoune/Manifest1
-rw-r--r--app-editors/kakoune/files/kakoune-makefile.patch40
-rw-r--r--app-editors/kakoune/kakoune-0_pre20160620.ebuild41
3 files changed, 0 insertions, 82 deletions
diff --git a/app-editors/kakoune/Manifest b/app-editors/kakoune/Manifest
index afcb832a7eb7..0ef5c4bdd7bf 100644
--- a/app-editors/kakoune/Manifest
+++ b/app-editors/kakoune/Manifest
@@ -1,2 +1 @@
-DIST kakoune-0_pre20160620.tar.gz 370523 SHA256 4344bc78a15942c01818c8e8a80f228249557f5d2d20c2fdc845faeef86abe2e SHA512 c186b9024db7956d9bcae925727c3f30dd2c2fb49995e97c56dbdf59c3f17989feb405086957818685a08530da0f2b58b5798687959267da7e9e2a25dd78003c WHIRLPOOL c555754e4fc3456ce7912d60adb72191349692d0465996893ceb1162cc5f7f61b08b0098f13a54d5d44c861aaf3b23eaea343813f055b8ca06f6ce1305a30f4d
DIST kakoune-0_pre20170523.tar.gz 420837 SHA256 3a083916729336dfd9e1e49cda62b5e3e881dbda7d6c7b5826377d5af15b1af9 SHA512 6d7d8f7afda75b824e4150512d9e0710cf22ef79af985c68b724a0f8e6949e5b0e7aab288f165a229f17706b30b51b462305538c7b56fd50689019118e913219 WHIRLPOOL 2e3a4c6b57944be46dbc8ddbc466fe3953453719146f4feabf8ae9688248a0d20ba2da3379fc7a503e7de7669df5f92d02e25dfc54c711a6ecdbee133b7a6ef8
diff --git a/app-editors/kakoune/files/kakoune-makefile.patch b/app-editors/kakoune/files/kakoune-makefile.patch
deleted file mode 100644
index 54a22d5ac925..000000000000
--- a/app-editors/kakoune/files/kakoune-makefile.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --git a/src/Makefile b/src/Makefile
-index c79c270..9409a8c 100644
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -3,10 +3,10 @@ pedantic ?= yes
-
- ifeq ($(debug),yes)
- CPPFLAGS += -DKAK_DEBUG
-+ CXXFLAGS += -g
- suffix := .debug
- else
- ifeq ($(debug),no)
-- CXXFLAGS += -O3
- suffix := .opt
- else
- $(error debug should be either yes or no)
-@@ -26,8 +26,6 @@ mandocs := $(docs:.asciidoc=.gz)
- PREFIX ?= /usr/local
- DESTDIR ?= # root dir
-
--NCURSESW_INCLUDE ?= /usr/include/ncursesw
--
- bindir := $(DESTDIR)$(PREFIX)/bin
- sharedir := $(DESTDIR)$(PREFIX)/share/kak
- docdir := $(DESTDIR)$(PREFIX)/share/doc/kak
-@@ -53,11 +51,10 @@ else ifneq (,$(findstring CYGWIN,$(os)))
-- LIBS += -lncursesw -lboost_regex -ldbghelp
-+ LIBS += -lboost_regex -ldbghelp
- else
-- LIBS += -lncursesw -lboost_regex
-+ LIBS += -lboost_regex
-- CPPFLAGS += -I$(NCURSESW_INCLUDE)
- LDFLAGS += -rdynamic
- endif
-
--CXXFLAGS += -std=gnu++11 -g -Wall -Wno-reorder -Wno-sign-compare -Wno-address
-+CXXFLAGS += -std=gnu++11 -Wall -Wno-reorder -Wno-sign-compare -Wno-address
-
- kak : $(objects)
- $(CXX) $(LDFLAGS) $(CXXFLAGS) $(objects) $(LIBS) -o $@
diff --git a/app-editors/kakoune/kakoune-0_pre20160620.ebuild b/app-editors/kakoune/kakoune-0_pre20160620.ebuild
deleted file mode 100644
index 1dbd83893043..000000000000
--- a/app-editors/kakoune/kakoune-0_pre20160620.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic toolchain-funcs vcs-snapshot
-
-REF="34c8e6a9cf15410a433c8a8c3901703708b85611"
-
-DESCRIPTION="Selection-oriented code editor inspired by vim"
-HOMEPAGE="https://github.com/mawww/kakoune"
-SRC_URI="https://github.com/mawww/${PN}/tarball/${REF} -> ${P}.tar.gz"
-
-LICENSE="Unlicense"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug"
-
-RDEPEND="
- sys-libs/ncurses:=[unicode]
- dev-libs/boost
-"
-DEPEND="
- app-text/asciidoc
- virtual/pkgconfig
- ${RDEPEND}
-"
-
-PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
-
-src_configure() {
- append-cppflags $(pkg-config --cflags ncursesw)
- append-libs $(pkg-config --libs ncursesw)
- export CXX=$(tc-getCXX)
- export debug=$(usex debug)
- S="${WORKDIR}/${P}/src"
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="/usr" docdir="${D}/usr/share/doc/${PF}" install
-}