summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-10-22 15:18:01 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-10-22 15:51:11 +0200
commitf05e81560b00bcb918ad1865206d832948b5070b (patch)
treee89a4e48966e741d284fe5331c360ca2831ccdfc /app-editors
parentprofiles/package.mask: Mask postgresql:9.2 #634028 (diff)
downloadgentoo-f05e81560b00bcb918ad1865206d832948b5070b.tar.gz
gentoo-f05e81560b00bcb918ad1865206d832948b5070b.tar.bz2
gentoo-f05e81560b00bcb918ad1865206d832948b5070b.zip
app-editors/vim-core: add a bunch of missing dies.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim-core/vim-core-8.0.1188.ebuild49
1 files changed, 26 insertions, 23 deletions
diff --git a/app-editors/vim-core/vim-core-8.0.1188.ebuild b/app-editors/vim-core/vim-core-8.0.1188.ebuild
index a009ebab1f38..083a0871ebed 100644
--- a/app-editors/vim-core/vim-core-8.0.1188.ebuild
+++ b/app-editors/vim-core/vim-core-8.0.1188.ebuild
@@ -33,7 +33,7 @@ pkg_setup() {
export LC_COLLATE="C"
# Gnome sandbox silliness. bug #114475.
- mkdir -p "${T}"/home
+ mkdir -p "${T}"/home || die "mkdir -p failed"
export HOME="${T}"/home
}
@@ -44,8 +44,9 @@ src_prepare() {
fi
# Fixup a script to use awk instead of nawk
- sed -i '1s|.*|#!'"${EPREFIX}"'/usr/bin/awk -f|' "${S}"/runtime/tools/mve.awk \
- || die "mve.awk sed failed"
+ sed -i \
+ -e '1s|.*|#!'"${EPREFIX}"'/usr/bin/awk -f|' \
+ "${S}"/runtime/tools/mve.awk || die "sed failed"
# Read vimrc and gvimrc from /etc/vim
echo '#define SYS_VIMRC_FILE "'${EPREFIX}'/etc/vim/vimrc"' >> "${S}"/src/feature.h
@@ -70,22 +71,25 @@ src_prepare() {
# correctly. To avoid some really entertaining error messages about stuff
# which isn't even in the source file being invalid, we'll do some trickery
# to make the error never occur. bug 66162 (02 October 2004 ciaranm)
- find "${S}" -name '*.c' | while read c ; do echo >> "$c" ; done
+ find "${S}" -name '*.c' | while read c; do
+ echo >> "$c" || die "echo failed"
+ done
# Try to avoid sandbox problems. Bug #114475.
- if [[ -d "${S}"/src/po ]] ; then
+ if [[ -d "${S}"/src/po ]]; then
sed -i -e \
'/-S check.vim/s,..VIM.,ln -s $(VIM) testvim \; ./testvim -X,' \
- "${S}"/src/po/Makefile
+ "${S}"/src/po/Makefile || die "sed failed"
fi
- if version_is_at_least 7.3.122 ; then
- cp "${S}"/src/config.mk.dist "${S}"/src/auto/config.mk
+ if version_is_at_least 7.3.122; then
+ cp -v "${S}"/src/config.mk.dist "${S}"/src/auto/config.mk || die "cp failed"
fi
# Bug #378107 - Build properly with >=perl-core/ExtUtils-ParseXS-3.20.0
if version_is_at_least 7.3 ; then
- sed -i "s:\\\$(PERLLIB)/ExtUtils/xsubpp:${EPREFIX}/usr/bin/xsubpp:" \
+ sed -i -e \
+ "s:\\\$(PERLLIB)/ExtUtils/xsubpp:${EPREFIX}/usr/bin/xsubpp:" \
"${S}"/src/Makefile || die 'sed for ExtUtils-ParseXS failed'
fi
@@ -110,13 +114,18 @@ src_configure() {
# (3) Notice auto/configure is newer than auto/config.mk
# (4) Run ./configure (with wrong args) to remake auto/config.mk
sed -i 's# auto/config\.mk:#:#' src/Makefile || die "Makefile sed failed"
- rm -f src/auto/configure
+
+ # Remove src/auto/configure file.
+ rm -v src/auto/configure || die "rm configure failed"
+
emake -j1 -C src autoconf
# This should fix a sandbox violation (see bug 24447). The hvc
# things are for ppc64, see bug 86433.
- for file in /dev/pty/s* /dev/console /dev/hvc/* /dev/hvc* ; do
- [[ -e ${file} ]] && addwrite $file
+ for file in /dev/pty/s* /dev/console /dev/hvc/* /dev/hvc*; do
+ if [[ -e "${file}" ]]; then
+ addwrite $file
+ fi
done
# Let Portage do the stripping. Some people like that.
@@ -141,9 +150,7 @@ src_configure() {
}
src_compile() {
- # The following allows emake to be used
emake -j1 -C src auto/osdef.h objects
-
emake tools
}
@@ -174,14 +181,14 @@ src_install() {
newins "${FILESDIR}"/vimrc-r5 vimrc
eprefixify "${ED}"/etc/vim/vimrc
- if use minimal ; then
+ if use minimal; then
# To save space, install only a subset of the files.
# Helps minimalize the livecd, bug 65144.
eshopts_push -s extglob
- rm -fr "${ED}${vimfiles}"/{compiler,doc,ftplugin,indent}
- rm -fr "${ED}${vimfiles}"/{macros,print,tools,tutor}
- rm "${ED}"/usr/bin/vimtutor
+ rm -rv "${ED}${vimfiles}"/{compiler,doc,ftplugin,indent} || die "rm failed"
+ rm -rv "${ED}${vimfiles}"/{macros,print,tools,tutor} || die "rm failed"
+ rm -v "${ED}"/usr/bin/vimtutor || die "rm failed"
local keep_colors="default"
ignore=$(rm -fr "${ED}${vimfiles}"/colors/!(${keep_colors}).vim )
@@ -197,13 +204,9 @@ src_install() {
# These files might have slight security issues, so we won't
# install them. See bug #77841. We don't mind if these don't
# exist.
- rm "${ED}${vimfiles}"/tools/{vimspell.sh,tcltags} 2>/dev/null
+ rm -v "${ED}${vimfiles}"/tools/vimspell.sh || die "rm failed"
newbashcomp "${FILESDIR}"/xxd-completion xxd
-
- # We shouldn't be installing the ex or view man page symlinks, as they
- # are managed by eselect-vi
- rm -f "${ED}"/usr/share/man/man1/{ex,view}.1
}
pkg_postinst() {