summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2020-03-05 21:56:06 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-11 23:03:40 +0100
commitfaf76fb9991c7dcc516b3c10292063a0af843898 (patch)
tree07b0b49678c64c58d596f5f74a6922aaf55f4e7c /app-editors
parentdev-python/uritemplate: 3.0.1 bump (diff)
downloadgentoo-faf76fb9991c7dcc516b3c10292063a0af843898.tar.gz
gentoo-faf76fb9991c7dcc516b3c10292063a0af843898.tar.bz2
gentoo-faf76fb9991c7dcc516b3c10292063a0af843898.zip
app-editors/ghostwriter: verbump to 1.8.1
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14859 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/ghostwriter/Manifest1
-rw-r--r--app-editors/ghostwriter/files/ghostwriter-1.8.1-appdata-path.patch27
-rw-r--r--app-editors/ghostwriter/ghostwriter-1.8.1.ebuild60
3 files changed, 88 insertions, 0 deletions
diff --git a/app-editors/ghostwriter/Manifest b/app-editors/ghostwriter/Manifest
index 39d80b85ecfc..6e6955ec8206 100644
--- a/app-editors/ghostwriter/Manifest
+++ b/app-editors/ghostwriter/Manifest
@@ -1 +1,2 @@
DIST ghostwriter-1.8.0.tar.gz 1195999 BLAKE2B d751e570aed94bcf0806ca20d82b0ac2b465649caf31f01b761f0370a4f1b04ac8f948213b15c05a71541b8068ef21dfb2105b5fc91d5637e498e2d4c8f6bf9a SHA512 aff500d9221f28f6a06a93bf0b5ddb590792b22bc551749b790f52751cd7f2e27ea59778927c2f117320cb1791b45d51d8efdf479f0894319755afb1a509f7bd
+DIST ghostwriter-1.8.1.tar.gz 1220000 BLAKE2B 3fa3d95ed819bc8f7b76b396e6634658a8bda23e9100cbb298d301fc382db451430a4a31fbd092326af198825c83d2c998172c90a7e318aeb57ef7799751995a SHA512 9f60f81a594cf161edfeac8c75830e186ab4ec2c22859b2bad40768e1ecf64e6842b52a69024a1f014d24a2f1cbb38e15a7799101d7fd54ef7709e245f6ac521
diff --git a/app-editors/ghostwriter/files/ghostwriter-1.8.1-appdata-path.patch b/app-editors/ghostwriter/files/ghostwriter-1.8.1-appdata-path.patch
new file mode 100644
index 000000000000..514ab6262e5a
--- /dev/null
+++ b/app-editors/ghostwriter/files/ghostwriter-1.8.1-appdata-path.patch
@@ -0,0 +1,27 @@
+From 5e63fa9cb6d4020413db071ed68aa85f3e79fd9e Mon Sep 17 00:00:00 2001
+From: David Roman <davidroman96@gmail.com>
+Date: Mon, 9 Mar 2020 21:42:58 +0100
+Subject: [PATCH] update appdata path
+
+The previous location is deprecated
+see https://www.freedesktop.org/software/appstream/docs/chap-Metadata.html
+---
+ ghostwriter.pro | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ghostwriter.pro b/ghostwriter.pro
+index d399fb5..7f5f22c 100644
+--- a/ghostwriter.pro
++++ b/ghostwriter.pro
+@@ -264,7 +264,7 @@ macx {
+ desktop.path = $$DATADIR/applications/
+
+ appdata.files = resources/linux/ghostwriter.appdata.xml
+- appdata.path = $$DATADIR/appdata/
++ appdata.path = $$DATADIR/metainfo/
+
+ man.files = resources/linux/ghostwriter.1
+ man.path = $$PREFIX/share/man/man1
+--
+2.25.1
+
diff --git a/app-editors/ghostwriter/ghostwriter-1.8.1.ebuild b/app-editors/ghostwriter/ghostwriter-1.8.1.ebuild
new file mode 100644
index 000000000000..0cad36834839
--- /dev/null
+++ b/app-editors/ghostwriter/ghostwriter-1.8.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg-utils
+
+DESCRIPTION="Cross-platform, aesthetic, distraction-free markdown editor"
+HOMEPAGE="https://wereturtle.github.io/ghostwriter/"
+SRC_URI="https://github.com/wereturtle/ghostwriter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+BDEPEND="dev-qt/linguist-tools:5"
+
+RDEPEND="
+ app-text/hunspell
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebchannel:5
+ dev-qt/qtwebengine:5[widgets]
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( CREDITS.md README.md )
+
+PATCHES=( "${FILESDIR}/${P}-appdata-path.patch" )
+
+src_prepare() {
+ default
+
+ sed -i -e "/^VERSION =/s/\$.*/${PV}/" ghostwriter.pro || die "failed to override version"
+}
+
+src_configure() {
+ eqmake5 \
+ CONFIG+=$(usex debug debug release) \
+ PREFIX="${EPREFIX}"/usr
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}