summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-07-23 12:45:07 +0200
committerUlrich Müller <ulm@gentoo.org>2021-07-23 12:49:22 +0200
commitd948150b3035a88b9384f87b38ef39f9a0e4d5c0 (patch)
tree4cf1e876ac63a41ceb82c81007c505d31b312b5d /app-emacs/apel
parentmedia-sound/brutefir: removed obsolete 1.0k-r2 (diff)
downloadgentoo-d948150b3035a88b9384f87b38ef39f9a0e4d5c0.tar.gz
gentoo-d948150b3035a88b9384f87b38ef39f9a0e4d5c0.tar.bz2
gentoo-d948150b3035a88b9384f87b38ef39f9a0e4d5c0.zip
app-emacs/apel: New snapshot 10.8_p20201106
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/apel')
-rw-r--r--app-emacs/apel/Manifest1
-rw-r--r--app-emacs/apel/apel-10.8_p20201106.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/apel/Manifest b/app-emacs/apel/Manifest
index 0b70654f9db2..c1bd6d74f583 100644
--- a/app-emacs/apel/Manifest
+++ b/app-emacs/apel/Manifest
@@ -1 +1,2 @@
DIST apel-10.8_p20190407.tar.gz 94808 BLAKE2B 47540e8c3ce96cc91efefe521942a3df4ee8423c7796d7e66b14bed7e9d662469a0767dd4863ae130fb114a1f9335d95abd13d61b6811e039db75e28679ac0f6 SHA512 6c780b0643f248e2a1409f1cea794dc6be515ee2ae766ead0834996bd9c13852492af1b9c343c4efda06fd057fae0c1b8a1ffc6b55b1469afbc7cbf1b579ea68
+DIST apel-10.8_p20201106.tar.gz 69188 BLAKE2B e0107968349fe73325503a61fbc9ada83d657f2ca66a39ae2ea833543277f536d22371e371e17dc4307380e738491e20ec0b7b52a35207f49e37fa65c66f3ab1 SHA512 fb14570d6d4f2346d386ae0012cfb9149ddf9ade8b4dc75507e6cef848d12ef65f80bd7d1dc26815031aee00461d67d4a86fe29e30d5d542756e725425634c77
diff --git a/app-emacs/apel/apel-10.8_p20201106.ebuild b/app-emacs/apel/apel-10.8_p20201106.ebuild
new file mode 100644
index 000000000000..85482a6ff306
--- /dev/null
+++ b/app-emacs/apel/apel-10.8_p20201106.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=24.5
+
+inherit elisp
+
+DESCRIPTION="A Portable Emacs Library is a library for making portable Emacs Lisp programs"
+HOMEPAGE="https://github.com/wanderlust/apel"
+GITHUB_SHA1="4e3269b6e702db2dba48cf560563ac883e81e3bf"
+SRC_URI="https://github.com/wanderlust/${PN}/archive/${GITHUB_SHA1}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${GITHUB_SHA1}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+
+SITEFILE="50apel-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+ cat <<-EOF >>APEL-CFG || die
+ (setq APEL_PREFIX "apel")
+ (setq EMU_PREFIX "apel")
+ EOF
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" \
+ LISPDIR="${ED}/${SITELISP}" \
+ VERSION_SPECIFIC_LISPDIR="${ED}/${SITELISP}" \
+ install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc ChangeLog* README*
+}