summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/auto-complete
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/auto-complete')
-rw-r--r--app-emacs/auto-complete/Manifest1
-rw-r--r--app-emacs/auto-complete/auto-complete-1.3.1.ebuild34
-rw-r--r--app-emacs/auto-complete/files/50auto-complete-gentoo.el3
-rw-r--r--app-emacs/auto-complete/metadata.xml8
4 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/auto-complete/Manifest b/app-emacs/auto-complete/Manifest
new file mode 100644
index 000000000000..c11db0c5c2d5
--- /dev/null
+++ b/app-emacs/auto-complete/Manifest
@@ -0,0 +1 @@
+DIST auto-complete-1.3.1.tar.bz2 155081 SHA256 9266b66be840582d1ce304a2c17eb63d2f4422cb6e69952be5f0b20baeeb9888 SHA512 5b82120f8faf1ee4ff139f4fbacb894fa0bf617b9a0aaebb5a0d672a6f90cb01bc35f0c99cebe2bef55cb7a6af6ce03936a7226c89e3c79248aacf4ae554fb7b WHIRLPOOL df05e94eaa75b0a326da8653202a8d7b607b8f7ebd8f252727e164d98e05d5d1b5cbd0396b7028f4fd16c6b3ad6a42a379c2ad4df0ae309ce4c0b50e1dd7683e
diff --git a/app-emacs/auto-complete/auto-complete-1.3.1.ebuild b/app-emacs/auto-complete/auto-complete-1.3.1.ebuild
new file mode 100644
index 000000000000..ae54fbcfcc47
--- /dev/null
+++ b/app-emacs/auto-complete/auto-complete-1.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Auto-complete package"
+HOMEPAGE="http://cx4a.org/software/auto-complete/
+ http://github.com/m2ym/auto-complete/"
+SRC_URI="http://cx4a.org/pub/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_ja"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+
+ # install dictionaries
+ insinto "${SITEETC}/${PN}"
+ doins -r dict
+
+ dodoc README.txt TODO.txt etc/test.txt
+ cd doc
+ dodoc index.txt manual.txt demo.txt changes.txt *.png
+ if use linguas_ja; then
+ dodoc index.ja.txt manual.ja.txt changes.ja.txt
+ fi
+}
diff --git a/app-emacs/auto-complete/files/50auto-complete-gentoo.el b/app-emacs/auto-complete/files/50auto-complete-gentoo.el
new file mode 100644
index 000000000000..c380d11b3a1e
--- /dev/null
+++ b/app-emacs/auto-complete/files/50auto-complete-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'auto-complete-mode "auto-complete" "AutoComplete mode" t)
+(setq ac-dictionary-directories "@SITEETC@/dict")
diff --git a/app-emacs/auto-complete/metadata.xml b/app-emacs/auto-complete/metadata.xml
new file mode 100644
index 000000000000..8ad6abfbb6ee
--- /dev/null
+++ b/app-emacs/auto-complete/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<upstream>
+ <remote-id type="github">m2ym/auto-complete</remote-id>
+</upstream>
+</pkgmetadata>