summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/blogmax
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/blogmax')
-rw-r--r--app-emacs/blogmax/Manifest1
-rw-r--r--app-emacs/blogmax/blogmax-20110305.ebuild44
-rw-r--r--app-emacs/blogmax/files/50blogmax-gentoo.el4
-rw-r--r--app-emacs/blogmax/files/README.Gentoo8
-rw-r--r--app-emacs/blogmax/metadata.xml8
5 files changed, 65 insertions, 0 deletions
diff --git a/app-emacs/blogmax/Manifest b/app-emacs/blogmax/Manifest
new file mode 100644
index 000000000000..495513a3a834
--- /dev/null
+++ b/app-emacs/blogmax/Manifest
@@ -0,0 +1 @@
+DIST blogmax-20110305.zip 194956 SHA256 c2143b7df9d194f0f97d9ddddf5e4bcabe5fdc78fd0b9cad200e2a528b5632c5 SHA512 dc0529c5d61ea9beaecf9dfdfe0631ae31fb9737845aa81f2ac7c19df7aa30eb7392f73ea96a00b678cd441f0815129bb04d521e697ce2cb3938d8699483d19b WHIRLPOOL f8fce4a9f37058f209c2076ba2473d6b57825204feb0ec68b39074c74e56b0fb6481bd640894e83dbb175b9cdec3df18b12bb408046b8186948deddfe8ede26f
diff --git a/app-emacs/blogmax/blogmax-20110305.ebuild b/app-emacs/blogmax/blogmax-20110305.ebuild
new file mode 100644
index 000000000000..34bc62db3726
--- /dev/null
+++ b/app-emacs/blogmax/blogmax-20110305.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils readme.gentoo elisp
+
+DESCRIPTION="Blogging in Emacs"
+HOMEPAGE="http://billstclair.com/blogmax/index.html"
+# taken from http://billstclair.com/blogmax.zip
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.zip"
+
+LICENSE="GPL-1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ rm *.elc gpl.txt || die
+ edos2unix *.{el,html,inc,ini,tmpl,txt,xml} docs/*.{html,txt}
+}
+
+src_compile() {
+ elisp-compile blogmax.el
+}
+
+src_install() {
+ elisp-install ${PN} blogmax.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ DOC_CONTENTS="To get started with BlogMax, use the example site file
+ from /usr/share/doc/${PF}/example as a template for your own blog."
+ readme.gentoo_create_doc
+
+ dodoc README
+ dodoc -r docs
+ docinto example
+ dodoc *.{html,inc,ini,png,tmpl,txt,xml}
+}
diff --git a/app-emacs/blogmax/files/50blogmax-gentoo.el b/app-emacs/blogmax/files/50blogmax-gentoo.el
new file mode 100644
index 000000000000..fc110114b3a6
--- /dev/null
+++ b/app-emacs/blogmax/files/50blogmax-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'weblog-mode "blogmax" "Weblog" t)
+(autoload 'weblog-set-buffer-mode "blogmax"
+ "Set the mode to weblog-mode for text files in the *weblog-directory*" t)
diff --git a/app-emacs/blogmax/files/README.Gentoo b/app-emacs/blogmax/files/README.Gentoo
new file mode 100644
index 000000000000..a737d0f9c9ac
--- /dev/null
+++ b/app-emacs/blogmax/files/README.Gentoo
@@ -0,0 +1,8 @@
+ -*-outline-*-
+* Getting Started With BlogMax
+
+Use the example site file from /usr/share/doc/blogmax-*/example as a
+template for your own blog.
+
+--
+Matthew Kennedy <mkennedy@gentoo.org>
diff --git a/app-emacs/blogmax/metadata.xml b/app-emacs/blogmax/metadata.xml
new file mode 100644
index 000000000000..152470076db1
--- /dev/null
+++ b/app-emacs/blogmax/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+BlogMax is an Emacs package that aids in the creation of a weblog.
+</longdescription>
+</pkgmetadata>