summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Gaydov <victor@enise.org>2016-04-24 23:43:11 +0300
committerUlrich Müller <ulm@gentoo.org>2016-05-01 19:29:02 +0200
commit6d2c182115a0c5baa22c8dc2e4d566674a1deba4 (patch)
tree96f46f111adea69bd7a353f85d785de6b36f2d93 /app-emacs/cycle-buffer/cycle-buffer-2.16.ebuild
parentapp-emacs/windows: Add version 2.49 (diff)
downloadgentoo-6d2c182115a0c5baa22c8dc2e4d566674a1deba4.tar.gz
gentoo-6d2c182115a0c5baa22c8dc2e4d566674a1deba4.tar.bz2
gentoo-6d2c182115a0c5baa22c8dc2e4d566674a1deba4.zip
app-emacs/cycle-buffer: Add version 2.16
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-emacs/cycle-buffer/cycle-buffer-2.16.ebuild')
-rw-r--r--app-emacs/cycle-buffer/cycle-buffer-2.16.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-emacs/cycle-buffer/cycle-buffer-2.16.ebuild b/app-emacs/cycle-buffer/cycle-buffer-2.16.ebuild
new file mode 100644
index 000000000000..2bea30182b44
--- /dev/null
+++ b/app-emacs/cycle-buffer/cycle-buffer-2.16.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="Select buffer by cycling through"
+HOMEPAGE="http://www.emacswiki.org/emacs/cycle-buffer.el"
+# taken from https://www.emacswiki.org/emacs/download/cycle-buffer.el
+SRC_URI="https://enise.org/users/victor/share/distfiles/${P}.el.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el || die
+ elisp-make-autoload-file || die
+}