summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-08 10:16:21 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-08 14:21:17 +0200
commit27369fb065a85e692eb150317f31c89ee1692b4d (patch)
treee9b67d0236a58643ccb01283fa41d1e38d913078 /app-emacs/eglot
parentapp-emacs/eglot: drop old 1.9 (diff)
downloadgentoo-27369fb065a85e692eb150317f31c89ee1692b4d.tar.gz
gentoo-27369fb065a85e692eb150317f31c89ee1692b4d.tar.bz2
gentoo-27369fb065a85e692eb150317f31c89ee1692b4d.zip
app-emacs/eglot: bump to 1.15
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/eglot')
-rw-r--r--app-emacs/eglot/Manifest1
-rw-r--r--app-emacs/eglot/eglot-1.15.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/eglot/Manifest b/app-emacs/eglot/Manifest
index e8dccb919286..9783cf07fe31 100644
--- a/app-emacs/eglot/Manifest
+++ b/app-emacs/eglot/Manifest
@@ -1,2 +1,3 @@
DIST eglot-1.11.tar.xz 36900 BLAKE2B 20496e37944127c0e209762d2455fad01e6578fd1fa8350cc1a6782ed3e5dc11b09f8b737cd97d5439ab7ef67caa5cdf725d53d2e9e91bbca10223106a9073ad SHA512 c258c89d8c81b1c1df8ea9798c120a7534c174ce435a4551f503c7477520619ac08bd627372033ed1740dfc67bf7e8004751259769844d6be9adc9411d8ae5ac
DIST eglot-1.13.tar.gz 303750 BLAKE2B ecd2efe5fcf2d0d8229336f01ced60f882cfb3e4a0a8af6bcd9f5da0e5cdc6d247634960de50fe46cd4fdac32ea83cd3b506fd025f109c684cb468a60969cbc4 SHA512 43e659213e8f2cedd0ecbd0a2bb1b475de37083577845574adb8bb61d20d0c72b8fc291689e1654c00156f8b2c03d29fc327f7adbac0eb0c5f88d851583f28b8
+DIST eglot-1.15.tar.gz 305200 BLAKE2B e9bb3f10dc9aac803f9b1184f489d76bd217b279d398c67a403c887298ec3e73e30a359a7e31af9c298b8778a2cdf916e9f40495ab3d01216a12fb38aed4d83b SHA512 871d56404c08baa490488d6027645f7ba0252faee7d006ade4e29890abb2e70a3f1715114c852721db7991bdece29266d920bbef6da0eb2ea2f37b842f411ac2
diff --git a/app-emacs/eglot/eglot-1.15.ebuild b/app-emacs/eglot/eglot-1.15.ebuild
new file mode 100644
index 000000000000..9ffaace3d84d
--- /dev/null
+++ b/app-emacs/eglot/eglot-1.15.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.3
+
+inherit elisp
+
+DESCRIPTION="A minimal Emacs LSP client for GNU Emacs"
+HOMEPAGE="https://github.com/joaotavora/eglot/
+ https://elpa.gnu.org/packages/eglot.html"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/joaotavora/${PN}.git"
+elif [[ ${PV} == 1.15 ]] ; then
+ COMMIT=8b5532dd32b25276c1857508030b207f765ef9b6
+ SRC_URI="https://github.com/joaotavora/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # Requires the newest "project" package.
+
+RDEPEND="app-emacs/external-completion"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+}