summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-13 00:18:03 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-13 00:18:03 +0200
commit4595fada0f67cdc9a41bbf8ab0d27d31a60629ff (patch)
tree0ccf11ed8e423b8cd33fdf3a32d92b49e42a1013 /app-emacs/eglot
parentapp-emacs/pkg-info: add the Gentoo GNU Emacs project to maintainers (diff)
downloadgentoo-4595fada0f67cdc9a41bbf8ab0d27d31a60629ff.tar.gz
gentoo-4595fada0f67cdc9a41bbf8ab0d27d31a60629ff.tar.bz2
gentoo-4595fada0f67cdc9a41bbf8ab0d27d31a60629ff.zip
app-emacs/eglot: bump to 1.8
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/eglot')
-rw-r--r--app-emacs/eglot/Manifest1
-rw-r--r--app-emacs/eglot/eglot-1.8.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/eglot/Manifest b/app-emacs/eglot/Manifest
index 1c18d5f83751..8148e48e5796 100644
--- a/app-emacs/eglot/Manifest
+++ b/app-emacs/eglot/Manifest
@@ -1 +1,2 @@
DIST eglot-1.6.tar.gz 288078 BLAKE2B a2214d216d0eeaca32d974c6686696dfcf141b3384741bc8cce0d02abb508eb5713933bc227d12a07f4b87fc34601431845b1b8e519538ae04ecc74b24db4004 SHA512 51227c8e2b0a1dd9a63ededbea592f01616ff728c34c330400c078212fef3f3e747e6dd30ba312523cbe60c7ea663a7af9d83300210cf331ea6162d2db5c7e41
+DIST eglot-1.8.tar.gz 302450 BLAKE2B 7247b11adaf9a65a2e071ca17b55038fe85f5842fb4155b44dbfa82bae5774e4cd2f7a5557d40cb1a7ab7f554233f15abe297e10568a1630b464ab6a600d978f SHA512 0295eff6dfbbf9d7a82349b8e5ed9e7dad700f2f0bfcab879d906e30bfbb4d28b8779fd9076108ac9b1594a60ca5e30c5035e2f8ceae44add99c28a843027609
diff --git a/app-emacs/eglot/eglot-1.8.ebuild b/app-emacs/eglot/eglot-1.8.ebuild
new file mode 100644
index 000000000000..913bb955411f
--- /dev/null
+++ b/app-emacs/eglot/eglot-1.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="26.1"
+
+inherit elisp
+
+DESCRIPTION="A minimal Emacs LSP client"
+HOMEPAGE="https://github.com/joaotavora/eglot"
+SRC_URI="https://github.com/joaotavora/eglot/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+# test requires internet connection to install several language servers, one of which
+# is not packaged
+RESTRICT="test"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_REMOVE="eglot-tests.el"
+DOCS=( README.md NEWS.md )
+
+src_install() {
+ elisp-make-autoload-file "${S}"/${PN}-autoload.el "${S}"/
+ elisp_src_install
+}