summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-10-30 07:29:32 +0100
committerUlrich Müller <ulm@gentoo.org>2017-10-30 07:29:32 +0100
commitc36d4c749d956f180653ed9fa6d61fa44eb01f05 (patch)
tree834bf900c20fe5a2e4b897a39ff568101a7149cd /app-emacs/emms/emms-4.3.ebuild
parentdev-lang/ruby: update postinst eselect message, bug 635614 (diff)
downloadgentoo-c36d4c749d956f180653ed9fa6d61fa44eb01f05.tar.gz
gentoo-c36d4c749d956f180653ed9fa6d61fa44eb01f05.tar.bz2
gentoo-c36d4c749d956f180653ed9fa6d61fa44eb01f05.zip
app-emacs/emms: Version bump.
Closes: https://bugs.gentoo.org/635796 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'app-emacs/emms/emms-4.3.ebuild')
-rw-r--r--app-emacs/emms/emms-4.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/emms/emms-4.3.ebuild b/app-emacs/emms/emms-4.3.ebuild
new file mode 100644
index 000000000000..1aacf114f268
--- /dev/null
+++ b/app-emacs/emms/emms-4.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="The Emacs Multimedia System"
+HOMEPAGE="https://www.gnu.org/software/emms/
+ https://www.emacswiki.org/emacs/EMMS"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="media-libs/taglib"
+RDEPEND="${DEPEND}"
+
+# EMMS can use almost anything for playing media files therefore the dependency
+# possibilities are so broad that we refrain from setting anything explicitly
+# in DEPEND/RDEPEND.
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
+ all emms-print-metadata
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo doc/emms.info*
+ dobin src/emms-print-metadata
+ doman emms-print-metadata.1
+ dodoc AUTHORS ChangeLog NEWS README THANKGNU
+}