summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-05-31 12:41:43 +0200
committerUlrich Müller <ulm@gentoo.org>2020-05-31 12:44:24 +0200
commit63331cb630933cf5f40ad365c5b70190ad7e9d00 (patch)
tree7ef8ce5040901dece2104d4011ac9596cae7c091 /app-emacs/emms/emms-5.4.ebuild
parentx11-plugins/fsviewer: Remove last-rited pkg (diff)
downloadgentoo-63331cb630933cf5f40ad365c5b70190ad7e9d00.tar.gz
gentoo-63331cb630933cf5f40ad365c5b70190ad7e9d00.tar.bz2
gentoo-63331cb630933cf5f40ad365c5b70190ad7e9d00.zip
app-emacs/emms: Version bump to 5.4.
Closes: https://bugs.gentoo.org/725338 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/emms/emms-5.4.ebuild')
-rw-r--r--app-emacs/emms/emms-5.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/emms/emms-5.4.ebuild b/app-emacs/emms/emms-5.4.ebuild
new file mode 100644
index 000000000000..332e0d00a88d
--- /dev/null
+++ b/app-emacs/emms/emms-5.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="The Emacs Multimedia System"
+HOMEPAGE="https://www.gnu.org/software/emms/
+ https://www.emacswiki.org/emacs/EMMS"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="media-libs/taglib"
+DEPEND="${RDEPEND}"
+
+# EMMS can use almost anything for playing media files therefore the dependency
+# possibilities are so broad that we refrain from setting anything explicitly
+# in DEPEND/RDEPEND.
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
+ all emms-print-metadata
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo doc/emms.info*
+ dobin src/emms-print-metadata
+ doman emms-print-metadata.1
+ dodoc AUTHORS ChangeLog NEWS README THANKGNU
+}