summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/eselect-mode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/eselect-mode')
-rw-r--r--app-emacs/eselect-mode/Manifest1
-rw-r--r--app-emacs/eselect-mode/eselect-mode-1.4.4.ebuild19
-rw-r--r--app-emacs/eselect-mode/eselect-mode-9999.ebuild20
-rw-r--r--app-emacs/eselect-mode/files/50eselect-mode-gentoo.el3
-rw-r--r--app-emacs/eselect-mode/metadata.xml6
5 files changed, 49 insertions, 0 deletions
diff --git a/app-emacs/eselect-mode/Manifest b/app-emacs/eselect-mode/Manifest
new file mode 100644
index 000000000000..c77de7fb1c7d
--- /dev/null
+++ b/app-emacs/eselect-mode/Manifest
@@ -0,0 +1 @@
+DIST eselect-1.4.4.tar.xz 177536 SHA256 120c123eae4a1d03515e94f9efd51af6ff2f09340daf1ada4dc21079df7a937f SHA512 1ed01cf00e3f13aad3e5f844c7086c3dd48398efd76e68cd91cf13b9939f4b48eef8915c5f3926954d158023115ad66ee67c0bc8fc4c9570900a37207674fc8f WHIRLPOOL e56c3ea3e54bdbcfffba3fbbe85b3c824cab796a0bae2680fac962356a2f707783571a9f73e0ea8299098838e593bea77b14edbeaadc372f186c2da2928e9ab5
diff --git a/app-emacs/eselect-mode/eselect-mode-1.4.4.ebuild b/app-emacs/eselect-mode/eselect-mode-1.4.4.ebuild
new file mode 100644
index 000000000000..1ffecdcff42f
--- /dev/null
+++ b/app-emacs/eselect-mode/eselect-mode-1.4.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+MY_P="eselect-${PV}"
+DESCRIPTION="Emacs major mode for editing eselect files"
+HOMEPAGE="http://wiki.gentoo.org/wiki/Project:Eselect"
+SRC_URI="http://dev.gentoo.org/~ulm/eselect/${MY_P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+S="${WORKDIR}/${MY_P}/misc"
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/eselect-mode/eselect-mode-9999.ebuild b/app-emacs/eselect-mode/eselect-mode-9999.ebuild
new file mode 100644
index 000000000000..b82c58c91f08
--- /dev/null
+++ b/app-emacs/eselect-mode/eselect-mode-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="eselect"
+EGIT_REPO_URI="git://anongit.gentoo.org/proj/eselect.git"
+EGIT_CHECKOUT_DIR="${WORKDIR}/${MY_PN}"
+
+inherit elisp git-r3
+
+DESCRIPTION="Emacs major mode for editing eselect files"
+HOMEPAGE="http://wiki.gentoo.org/wiki/Project:Eselect"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+S="${WORKDIR}/${MY_PN}/misc"
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/eselect-mode/files/50eselect-mode-gentoo.el b/app-emacs/eselect-mode/files/50eselect-mode-gentoo.el
new file mode 100644
index 000000000000..05e2275ee322
--- /dev/null
+++ b/app-emacs/eselect-mode/files/50eselect-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'eselect-mode "eselect-mode" "Major mode for .eselect files." t)
+(add-to-list 'auto-mode-alist '("\\.eselect\\'" . eselect-mode))
diff --git a/app-emacs/eselect-mode/metadata.xml b/app-emacs/eselect-mode/metadata.xml
new file mode 100644
index 000000000000..b2c96c69ba47
--- /dev/null
+++ b/app-emacs/eselect-mode/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>eselect</herd>
+<herd>emacs</herd>
+</pkgmetadata>