summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Gaydov <victor@enise.org>2016-10-27 00:02:36 +0300
committerUlrich Müller <ulm@gentoo.org>2016-11-27 12:26:46 +0100
commit365550553f9b76ed2543e091a54c86d3af49c09c (patch)
tree972d5155bdd09980d24d20f79401c561cef98600 /app-emacs/expand-region/expand-region-0.11.0.ebuild
parentmedia-gfx/graphicsmagick: clean vulnerable wrt sec bug #574404 (diff)
downloadgentoo-365550553f9b76ed2543e091a54c86d3af49c09c.tar.gz
gentoo-365550553f9b76ed2543e091a54c86d3af49c09c.tar.bz2
gentoo-365550553f9b76ed2543e091a54c86d3af49c09c.zip
app-emacs/expand-region: new package
expand-region.el is emacs extension to increase selected region by semantic units. Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=598158
Diffstat (limited to 'app-emacs/expand-region/expand-region-0.11.0.ebuild')
-rw-r--r--app-emacs/expand-region/expand-region-0.11.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/expand-region/expand-region-0.11.0.ebuild b/app-emacs/expand-region/expand-region-0.11.0.ebuild
new file mode 100644
index 000000000000..ae6377a960a0
--- /dev/null
+++ b/app-emacs/expand-region/expand-region-0.11.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="Emacs extension to increase selected region by semantic units"
+HOMEPAGE="https://github.com/magnars/expand-region.el"
+SRC_URI="https://github.com/magnars/expand-region.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/expand-region.el-${PV}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}