summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-04-25 22:44:13 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-04-25 23:03:26 +0200
commit3d7cdd7b5d6d0d85d23c1717bfee993621ccad48 (patch)
tree7783177684b08a9daf103b577df967f39c743909 /app-emacs/fennel-mode/fennel-mode-0.9.1.ebuild
parentapp-shells/ugit: bump to 0.4.4 (diff)
downloadgentoo-3d7cdd7b5d6d0d85d23c1717bfee993621ccad48.tar.gz
gentoo-3d7cdd7b5d6d0d85d23c1717bfee993621ccad48.tar.bz2
gentoo-3d7cdd7b5d6d0d85d23c1717bfee993621ccad48.zip
app-emacs/fennel-mode: bump to 0.9.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/fennel-mode/fennel-mode-0.9.1.ebuild')
-rw-r--r--app-emacs/fennel-mode/fennel-mode-0.9.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/fennel-mode/fennel-mode-0.9.1.ebuild b/app-emacs/fennel-mode/fennel-mode-0.9.1.ebuild
new file mode 100644
index 000000000000..74f28faa0d18
--- /dev/null
+++ b/app-emacs/fennel-mode/fennel-mode-0.9.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT=b3c52964eda7c0267f6e3f0ad6c690c3a1e89da1
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Emacs support for the Fennel programming language"
+HOMEPAGE="https://git.sr.ht/~technomancy/fennel-mode/"
+SRC_URI="https://git.sr.ht/~technomancy/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${COMMIT}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( Readme.md changelog.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}"
+ doins syntax.fnl
+}