summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-10-17 15:39:42 +0200
committerUlrich Müller <ulm@gentoo.org>2019-10-17 15:49:11 +0200
commit9a2a5852bd8272c58b95e839e4d5c8d10c2a0c46 (patch)
treefd369109992136ab8749644f8be4398a4f216ca4 /app-emacs/gnuserv
parentapp-metrics/pushgateway: Version bump to 1.0.0 (diff)
downloadgentoo-9a2a5852bd8272c58b95e839e4d5c8d10c2a0c46.tar.gz
gentoo-9a2a5852bd8272c58b95e839e4d5c8d10c2a0c46.tar.bz2
gentoo-9a2a5852bd8272c58b95e839e4d5c8d10c2a0c46.zip
app-emacs/gnuserv: Fix backquotes patch.
This is mostly cosmetic, because the affected code in gnuserv-compat.el won't be called in current Emacs versions. Therefore committing this straight to stable. Bump EAPI to 7. Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/gnuserv')
-rw-r--r--app-emacs/gnuserv/files/gnuserv-3.12.8-backquotes.patch4
-rw-r--r--app-emacs/gnuserv/gnuserv-3.12.8-r5.ebuild (renamed from app-emacs/gnuserv/gnuserv-3.12.8-r4.ebuild)4
2 files changed, 4 insertions, 4 deletions
diff --git a/app-emacs/gnuserv/files/gnuserv-3.12.8-backquotes.patch b/app-emacs/gnuserv/files/gnuserv-3.12.8-backquotes.patch
index a16124821ddb..fa31ac2e4017 100644
--- a/app-emacs/gnuserv/files/gnuserv-3.12.8-backquotes.patch
+++ b/app-emacs/gnuserv/files/gnuserv-3.12.8-backquotes.patch
@@ -7,10 +7,10 @@ Use new-style backquotes, to make it compile with Emacs 27.
nil)
(defmacro defcustom (var value doc &rest args)
- (` (defvar (, var) (, value) (, doc))))
-+ `(defvar (, var) (, value) (, doc)))
++ `(defvar ,var ,value ,doc))
(defmacro defface (var value doc &rest args)
- (` (make-face (, var))))
-+ `(make-face (, var)))
++ `(make-face ,var))
(defmacro define-widget (&rest args)
nil)))
diff --git a/app-emacs/gnuserv/gnuserv-3.12.8-r4.ebuild b/app-emacs/gnuserv/gnuserv-3.12.8-r5.ebuild
index b7852e0d2632..94972c40cfd3 100644
--- a/app-emacs/gnuserv/gnuserv-3.12.8-r4.ebuild
+++ b/app-emacs/gnuserv/gnuserv-3.12.8-r5.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit elisp multilib desktop xdg-utils