summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-12-07 08:03:04 +0100
committerHans de Graaff <graaff@gentoo.org>2016-12-07 08:03:58 +0100
commit89816cdc2d2534c1a5043ac4e47a9c82bf8b0858 (patch)
tree45dedb38fca5914cbb4dd784eb0fe0de7cd45c90 /app-emacs/magit/magit-2.9.0.ebuild
parentapp-emacs/with-editor: add 2.5.8 (diff)
downloadgentoo-89816cdc2d2534c1a5043ac4e47a9c82bf8b0858.tar.gz
gentoo-89816cdc2d2534c1a5043ac4e47a9c82bf8b0858.tar.bz2
gentoo-89816cdc2d2534c1a5043ac4e47a9c82bf8b0858.zip
app-emacs/magit: add 2.9.0; also fix version status, bug 601260
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-emacs/magit/magit-2.9.0.ebuild')
-rw-r--r--app-emacs/magit/magit-2.9.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/magit/magit-2.9.0.ebuild b/app-emacs/magit/magit-2.9.0.ebuild
new file mode 100644
index 000000000000..1b125df5b315
--- /dev/null
+++ b/app-emacs/magit/magit-2.9.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A Git porcelain inside Emacs"
+HOMEPAGE="http://magit.vc/"
+SRC_URI="https://github.com/magit/magit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${P}/lisp"
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="../Documentation/*.texi"
+DOCS="../README.md ../Documentation/AUTHORS.md ../Documentation/RelNotes/${PV}.txt"
+
+DEPEND=">=app-emacs/dash-2.13.0 >=app-emacs/with-editor-2.5.8"
+RDEPEND="${DEPEND} >=dev-vcs/git-1.9.4"
+
+src_prepare() {
+ default
+ echo "(setq magit-version \"${PV}\")" > magit-version.el || die
+}