summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/magit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/magit')
-rw-r--r--app-emacs/magit/Manifest2
-rw-r--r--app-emacs/magit/files/50magit-gentoo.el2
-rw-r--r--app-emacs/magit/files/magit-1.2.0-delete-directory.patch33
-rw-r--r--app-emacs/magit/magit-1.2.0-r1.ebuild43
-rw-r--r--app-emacs/magit/magit-1.2.2.ebuild41
-rw-r--r--app-emacs/magit/metadata.xml21
6 files changed, 142 insertions, 0 deletions
diff --git a/app-emacs/magit/Manifest b/app-emacs/magit/Manifest
new file mode 100644
index 000000000000..1e3dd27cef6b
--- /dev/null
+++ b/app-emacs/magit/Manifest
@@ -0,0 +1,2 @@
+DIST magit-1.2.0.tar.gz 163318 SHA256 ef535819b8ee32c53ad38efabc82028f62422f2629407d69ddc5970669dc1ba9 SHA512 3f673d38d9f73cdf653108184ed97c1d499492224be3925949ffadb3bb6900a9be664c773dae49da696c6e1daa8bbb70d7446a9f9d7f9a7f8714ca254ed02c3d WHIRLPOOL 0462ea59ae75c01992d6d7dd17783ab4c60c335c17e03a8791be0771caf54d6a546a84c0622f2c1d45d1231a8d2638fb936bff31c94aa08a10d2c98e5986e4a4
+DIST magit-1.2.2.tar.gz 111245 SHA256 8ed300887909d0990cf17b1f4a3b902944db2471ca93dbf0202724b3f44e5d0c SHA512 c7817a5231485e593e8f7aab8c01db19f433ff9b77d6635c95eec6beabb45901f1dbd9d02fad718436f9e25516df14714e7ca1b05b53244e8465dcc14a8cee7a WHIRLPOOL 4b7116bf2568f786a859299ed8039bee32fda51322e29f7ddd139a9ee5e3f3a3caa9d245fffed3e6c28f11b0e068c398f424450275de94a4559a9812634639a0
diff --git a/app-emacs/magit/files/50magit-gentoo.el b/app-emacs/magit/files/50magit-gentoo.el
new file mode 100644
index 000000000000..87586cc7317d
--- /dev/null
+++ b/app-emacs/magit/files/50magit-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'magit-status "magit" nil t)
diff --git a/app-emacs/magit/files/magit-1.2.0-delete-directory.patch b/app-emacs/magit/files/magit-1.2.0-delete-directory.patch
new file mode 100644
index 000000000000..6c85345e9460
--- /dev/null
+++ b/app-emacs/magit/files/magit-1.2.0-delete-directory.patch
@@ -0,0 +1,33 @@
+Fix byte-compile failure with Emacs 24.3.91.
+
+The upstream git repo has a more complicated fix which we don't use,
+because the Gentoo package need not care about Emacs 22 and XEmacs
+compatibility. Instead, always define magit-delete-directory as an
+alias of delete-directory. This will work for all supported Emacs
+versions.
+
+--- magit-1.2.0-orig/magit.el
++++ magit-1.2.0/magit.el
+@@ -775,21 +775,7 @@
+ after-change-functions)
+ ,@body)))))
+
+- (if (>= (magit-max-args-internal 'delete-directory) 2)
+- (defalias 'magit-delete-directory 'delete-directory)
+- (defun magit-delete-directory (directory &optional recursive)
+- "Deletes a directory named DIRECTORY. If RECURSIVE is non-nil,
+-recursively delete all of DIRECTORY's contents as well.
+-
+-Does not follow symlinks."
+- (if (or (file-symlink-p directory)
+- (not (file-directory-p directory)))
+- (delete-file directory)
+- (if recursive
+- ;; `directory-files-no-dot-files-regex' borrowed from Emacs 23
+- (dolist (file (directory-files directory 'full "\\([^.]\\|\\.\\([^.]\\|\\..\\)\\).*"))
+- (magit-delete-directory file recursive)))
+- (delete-directory directory)))))
++ (defalias 'magit-delete-directory 'delete-directory))
+
+ ;;; Utilities
+
diff --git a/app-emacs/magit/magit-1.2.0-r1.ebuild b/app-emacs/magit/magit-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..4ac01155dfad
--- /dev/null
+++ b/app-emacs/magit/magit-1.2.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="An Emacs mode for GIT"
+HOMEPAGE="http://magit.github.io/"
+SRC_URI="http://github.com/downloads/magit/magit/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.2+"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="contrib"
+
+ELISP_PATCHES="${P}-delete-directory.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+RESTRICT="test"
+
+src_compile() {
+ # The upstream build system ignores errors during byte-compilation
+ # and happily installs broken files, causing errors at runtime.
+ # Call elisp-compile, in order to catch them here already.
+ elisp-compile *.el
+ emake core docs
+ use contrib && emake contrib
+ rm 50magit.el magit-pkg.el || die
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ doinfo magit.info
+ dodoc README.md
+
+ if use contrib; then
+ elisp-install ${PN} contrib/*.{el,elc} || die
+ dobin contrib/magit
+ fi
+}
diff --git a/app-emacs/magit/magit-1.2.2.ebuild b/app-emacs/magit/magit-1.2.2.ebuild
new file mode 100644
index 000000000000..b70c3e9f4981
--- /dev/null
+++ b/app-emacs/magit/magit-1.2.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="An Emacs mode for GIT"
+HOMEPAGE="http://magit.github.io/"
+SRC_URI="https://github.com/magit/magit/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.2+"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="contrib"
+RESTRICT="test"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ # The upstream build system ignores errors during byte-compilation
+ # and happily installs broken files, causing errors at runtime.
+ # Call elisp-compile, in order to catch them here already.
+ elisp-compile *.el
+ emake core docs
+ use contrib && emake contrib
+ rm 50magit.el magit-pkg.el || die
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo magit.info
+ dodoc README.md
+
+ if use contrib; then
+ elisp-install ${PN} contrib/*.{el,elc}
+ dobin contrib/magit
+ fi
+}
diff --git a/app-emacs/magit/metadata.xml b/app-emacs/magit/metadata.xml
new file mode 100644
index 000000000000..b95826009842
--- /dev/null
+++ b/app-emacs/magit/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ Magit is an interface to the version control system Git, implemented as an
+ extension to Emacs.
+
+ With Magit, you can inspect and modify your Git repositories with Emacs.
+ You can review and commit the changes you have made to the tracked files,
+ for example, and you can browse the history of past changes. There is
+ support for cherry picking, reverting, merging, rebasing, and other common
+ Git operations.
+</longdescription>
+<use>
+ <flag name="contrib">Install user-contributed files</flag>
+</use>
+<upstream>
+ <remote-id type="github">magit/magit</remote-id>
+</upstream>
+</pkgmetadata>