summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-08-03 05:47:26 +0200
committerHans de Graaff <graaff@gentoo.org>2021-08-03 06:54:08 +0200
commitabe22fe66a50286860b21cc54e4ee18b7d48e1d3 (patch)
treee137f8edc38b6c91cc2359077f0d87c2b6963f8c /app-emacs/magit
parentsys-devel/llvm-roc: update github id. (diff)
downloadgentoo-abe22fe66a50286860b21cc54e4ee18b7d48e1d3.tar.gz
gentoo-abe22fe66a50286860b21cc54e4ee18b7d48e1d3.tar.bz2
gentoo-abe22fe66a50286860b21cc54e4ee18b7d48e1d3.zip
app-emacs/magit: add 3.2.0
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-emacs/magit')
-rw-r--r--app-emacs/magit/Manifest1
-rw-r--r--app-emacs/magit/magit-3.2.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/magit/Manifest b/app-emacs/magit/Manifest
index 9db06e7e6367..1c9f2af9dd42 100644
--- a/app-emacs/magit/Manifest
+++ b/app-emacs/magit/Manifest
@@ -2,3 +2,4 @@ DIST magit-2.13.1.tar.gz 520271 BLAKE2B fdffa561dccaafc2be56bf285e286859145e00f5
DIST magit-2.90.1.tar.gz 544968 BLAKE2B d3a38cf8c4d8c15529463028c4f6718d65bff044f91f58f2027c62d584202835d17229ec1db93d2990b5bb59403eabf7f12e7e91e2de519149ad40c274da5f25 SHA512 57a81fc72276907009fd3d05abbaed930d089d3e4621d539abb6ce2b24fd594950533f47d60682e25f0bd1c9f1ab3a16ba6b2698d79c6980f250ffd335be7789
DIST magit-3.0.0.tar.gz 610528 BLAKE2B b667a6f12020f37303fa5d5c8bc71cb8f66bd25acbed704f3b3ba666b95b656da8c1b979d592e58171dd7bbaa4896b8fa144f52ec65e28976a88f42917df9323 SHA512 f1bb0d96906d327bb929cc45e2496a214513b1da4fd68e78a3db188f19dd69bd253c83e6b7881713989ee2a70d2f2cfdc9414263e0ee09be34cd72eb7fcb198d
DIST magit-3.1.0.tar.gz 613295 BLAKE2B b2ab1e56d1dcab7476fcfd22563452c0b6977a90f9d614911f13fb9eb591b75197d3ba7f74a1acab9eee464d4ab8d3c63e2019e7b974b3895d4a9851e37887e7 SHA512 b4e884aea1d6b0cbf7861016b7fbc8214911ea84afd349320c929368a245da31105555e644d4e2e9f5aa6787202c9c30c24e62f64f5671cc036273c22ab65bfc
+DIST magit-3.2.0.tar.gz 618602 BLAKE2B c96226669bc5160460d24a1b9b36784d6764234e2e2690f059c362176e9a56fc742b961a0d4103049b33d958e44c092f4bbb75de3b3437ac178dae89e34028e0 SHA512 3b4bd5a13592814c0c638a26ba09c6e01a15db6af3555db41bc0adc53e8c08eaa2e7c58d8a105101fb46a8a04be0e09a0f2c86d365391430b42adee83df382f6
diff --git a/app-emacs/magit/magit-3.2.0.ebuild b/app-emacs/magit/magit-3.2.0.ebuild
new file mode 100644
index 000000000000..fc3d6da779de
--- /dev/null
+++ b/app-emacs/magit/magit-3.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="A Git porcelain inside Emacs"
+HOMEPAGE="https://magit.vc/"
+SRC_URI="https://github.com/magit/magit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${P}/lisp"
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="../Documentation/*.texi"
+DOCS="../README.md ../Documentation/AUTHORS.md ../Documentation/RelNotes/*"
+
+DEPEND="
+ >=app-emacs/dash-2.18.1
+ app-emacs/libegit2
+ >=app-emacs/transient-0.3.6
+ >=app-emacs/with-editor-3.0.4
+"
+RDEPEND="${DEPEND} >=dev-vcs/git-2.0.0"
+DEPEND="${DEPEND} sys-apps/texinfo"
+
+src_prepare() {
+ default
+ echo "(setq magit-version \"${PV}\")" > magit-version.el || die
+}