summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-19 21:10:31 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-19 22:40:08 +0200
commitf9910dbbd8e8cf610451812eabcbae0c7a9397c4 (patch)
tree083c5dee576275eb6704840cd4967c080278e0df /app-emacs/noflet
parentapp-emacs/package-build: new package; add version 2.4 (diff)
downloadgentoo-f9910dbbd8e8cf610451812eabcbae0c7a9397c4.tar.gz
gentoo-f9910dbbd8e8cf610451812eabcbae0c7a9397c4.tar.bz2
gentoo-f9910dbbd8e8cf610451812eabcbae0c7a9397c4.zip
app-emacs/noflet: new package; add version 0.0.15_p20141102
2014.11.02 snapshot Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/noflet')
-rw-r--r--app-emacs/noflet/Manifest1
-rw-r--r--app-emacs/noflet/files/50noflet-gentoo.el1
-rw-r--r--app-emacs/noflet/files/noflet-fix-requires.patch28
-rw-r--r--app-emacs/noflet/metadata.xml13
-rw-r--r--app-emacs/noflet/noflet-0.0.15_p20141102.ebuild24
5 files changed, 67 insertions, 0 deletions
diff --git a/app-emacs/noflet/Manifest b/app-emacs/noflet/Manifest
new file mode 100644
index 000000000000..dad4228ae88a
--- /dev/null
+++ b/app-emacs/noflet/Manifest
@@ -0,0 +1 @@
+DIST noflet-0.0.15_p20141102.tar.gz 3123 BLAKE2B 0886da1af599e8ca226fbbefa31b6130c76d704d62c5323803543c31e975c375c1cfc12a5a3cfb5e2491488a31fce5538ab80f826de43fa4c77bdc7e8bd84315 SHA512 7007cb09f3ceaba652042a1ba9ff669e73b0a01775de573f0cfab33eef963e7b9125bb16ce1cd809479ea3ec0277eeed757a716538b1ca1f5b559b1ecdf7ed73
diff --git a/app-emacs/noflet/files/50noflet-gentoo.el b/app-emacs/noflet/files/50noflet-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/noflet/files/50noflet-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/noflet/files/noflet-fix-requires.patch b/app-emacs/noflet/files/noflet-fix-requires.patch
new file mode 100644
index 000000000000..142229d547e1
--- /dev/null
+++ b/app-emacs/noflet/files/noflet-fix-requires.patch
@@ -0,0 +1,28 @@
+index 58d3b8d..c003987 100644
+--- a/noflet.el
++++ b/noflet.el
+@@ -28,10 +28,8 @@
+
+ ;;; Code:
+
+-(eval-when-compile (require 'cl))
+-(if (version< emacs-version "24.4.1")
+- (load-library "cl-indent")
+- (require 'cl-indent))
++(require 'dash)
++(require 'cl-lib)
+
+ (defun noflet|base ()
+ "A base function."
+index 58d3b8d..73f0719 100644
+--- a/noflet.el
++++ b/noflet.el
+@@ -155,7 +155,7 @@ maintainers refuse to add the correct indentation spec to
+ (indent noflet-indent-func))
+ `(cl-flet ,bindings ,@body))
+
+-(defmacro* letn (tag bindings &rest body)
++(cl-defmacro letn (tag bindings &rest body)
+ (declare (debug (sexp sexp &rest form))
+ (indent 2))
+ `(cl-labels ((,tag ,(-map 'car bindings) ,@body))
diff --git a/app-emacs/noflet/metadata.xml b/app-emacs/noflet/metadata.xml
new file mode 100644
index 000000000000..09739af554d8
--- /dev/null
+++ b/app-emacs/noflet/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/nicferrier/emacs-noflet/issues/</bugs-to>
+ <remote-id type="github">nicferrier/emacs-noflet</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/noflet/noflet-0.0.15_p20141102.ebuild b/app-emacs/noflet/noflet-0.0.15_p20141102.ebuild
new file mode 100644
index 000000000000..07221b00caff
--- /dev/null
+++ b/app-emacs/noflet/noflet-0.0.15_p20141102.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=7ae84dc3257637af7334101456dafe1759c6b68a
+
+inherit elisp
+
+DESCRIPTION="Dynamic, local advice for Emacs-Lisp code"
+HOMEPAGE="https://github.com/nicferrier/emacs-noflet/"
+SRC_URI="https://github.com/nicferrier/emacs-${PN}/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${PN}-${H}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.creole )
+PATCHES=( "${FILESDIR}"/${PN}-fix-requires.patch )
+
+ELISP_REMOVE="let-while-tests.el"
+SITEFILE="50${PN}-gentoo.el"