summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-05-25 21:42:20 +0200
committerUlrich Müller <ulm@gentoo.org>2022-05-26 08:09:32 +0200
commit5db031f1e3b72231f15b39cc8d2e1894e618e579 (patch)
tree2bfacd772255c4b0e43ea2f35d93a889cc5d3d3e /app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220525.ebuild
parentx11-terms/kitty: sync live (diff)
downloadgentoo-5db031f1e3b72231f15b39cc8d2e1894e618e579.tar.gz
gentoo-5db031f1e3b72231f15b39cc8d2e1894e618e579.tar.bz2
gentoo-5db031f1e3b72231f15b39cc8d2e1894e618e579.zip
app-emacs/nxml-gentoo-schemas: add 20220525
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220525.ebuild')
-rw-r--r--app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220525.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220525.ebuild b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220525.ebuild
new file mode 100644
index 000000000000..e59b183875b9
--- /dev/null
+++ b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20220525.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Extension for nxml-mode with Gentoo-specific schemas"
+HOMEPAGE="https://gitweb.gentoo.org/proj/nxml-gentoo-schemas.git/"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="MIT GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+SITEFILE="60${PN}-gentoo.el"
+
+src_compile() { :; }
+
+src_install() {
+ insinto "${SITEETC}/${PN}"
+ doins schemas.xml *.rnc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}