summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-08-23 13:41:07 +0200
committerUlrich Müller <ulm@gentoo.org>2019-08-23 13:42:43 +0200
commit74f8c3ec446b2b9425c20817940ca1fcef55cafb (patch)
tree7c0b51f8a7091ca99cdd5eb87939b6f09d4a6a5d /app-emacs/pov-mode/pov-mode-3.3-r1.ebuild
parentapp-emacs/actionscript-mode: New snapshot. (diff)
downloadgentoo-74f8c3ec446b2b9425c20817940ca1fcef55cafb.tar.gz
gentoo-74f8c3ec446b2b9425c20817940ca1fcef55cafb.tar.bz2
gentoo-74f8c3ec446b2b9425c20817940ca1fcef55cafb.zip
app-emacs/pov-mode: Update HOMEPAGE and SRC_URI.
Bump EAPI to 7. Specify LICENSE more precisely. Files in the tarball (and therefore, files installed by the package) haven't changed. However, the checksum of the tarball at the new location is different, presumably due to upstream repacking. Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/pov-mode/pov-mode-3.3-r1.ebuild')
-rw-r--r--app-emacs/pov-mode/pov-mode-3.3-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/pov-mode/pov-mode-3.3-r1.ebuild b/app-emacs/pov-mode/pov-mode-3.3-r1.ebuild
new file mode 100644
index 000000000000..62ecc80c9bd1
--- /dev/null
+++ b/app-emacs/pov-mode/pov-mode-3.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Major mode for Povray scene files"
+HOMEPAGE="https://github.com/emacsmirror/pov-mode"
+SRC_URI="https://github.com/emacsmirror/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="sys-apps/texinfo"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_REMOVE="${PN}-pkg.el ${PN}.info"
+ELISP_TEXINFO="info/${PN}.texi"
+DOCS="README"
+
+src_install() {
+ elisp_src_install
+ insinto ${SITEETC}/${PN}
+ doins *.xpm
+ doins -r InsertMenu/
+}