summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/regress
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/regress')
-rw-r--r--app-emacs/regress/Manifest1
-rw-r--r--app-emacs/regress/files/1.5.1-regress.el-gentoo.patch11
-rw-r--r--app-emacs/regress/files/50regress-gentoo.el5
-rw-r--r--app-emacs/regress/metadata.xml9
-rw-r--r--app-emacs/regress/regress-1.5.1.ebuild18
5 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/regress/Manifest b/app-emacs/regress/Manifest
new file mode 100644
index 000000000000..2af0e04c9894
--- /dev/null
+++ b/app-emacs/regress/Manifest
@@ -0,0 +1 @@
+DIST regress-1.5.1.tar.gz 8633 SHA256 9be43cde347106c3979526b1049cf7af080dd9a6f8c71446562e78f1d871c81d SHA512 8718d44fc8cd62b9f02f53e59b0843f23cd9f1852c8f3c3038a3009b72f65efff94ac0fa9a18356d5efe7dde593e4643ed17fb54b5cc602f60c730cbb5cbd64a WHIRLPOOL d2c3f7d94e3d1a9807fba12e938ed6ca5accbb2a5d68283160996a01fbcbed5b350b037970562a894f046da5514a611b2375161b5713913b21cbd05835195e08
diff --git a/app-emacs/regress/files/1.5.1-regress.el-gentoo.patch b/app-emacs/regress/files/1.5.1-regress.el-gentoo.patch
new file mode 100644
index 000000000000..a66081ed759c
--- /dev/null
+++ b/app-emacs/regress/files/1.5.1-regress.el-gentoo.patch
@@ -0,0 +1,11 @@
+--- regress-1.5.1.orig/regress.el 2005-06-29 12:53:39.000000000 -0500
++++ regress-1.5.1/regress.el 2005-06-30 10:11:38.000000000 -0500
+@@ -114,6 +114,8 @@
+ ;; regression test fails and FAILURE-INDICATION is non-nil, it will
+ ;; be printed along with the results.
+
++(eval-when-compile
++ (require 'cl))
+
+ ;; Here are some contrived, simple examples. Much of regress.el
+ ;; itself contains regression tests. Search for "eval-when-compile",
diff --git a/app-emacs/regress/files/50regress-gentoo.el b/app-emacs/regress/files/50regress-gentoo.el
new file mode 100644
index 000000000000..307bf13f1477
--- /dev/null
+++ b/app-emacs/regress/files/50regress-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'regress-insert-suite "regress" nil t)
+(autoload 'regress-insert-call "regress" nil t)
+(autoload 'regress-forget "regress" nil t)
+(autoload 'regress "regress" nil t)
diff --git a/app-emacs/regress/metadata.xml b/app-emacs/regress/metadata.xml
new file mode 100644
index 000000000000..97e784644cc2
--- /dev/null
+++ b/app-emacs/regress/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+This module provides support for writing and executing regression
+tests for Emacs Lisp code.
+</longdescription>
+</pkgmetadata>
diff --git a/app-emacs/regress/regress-1.5.1.ebuild b/app-emacs/regress/regress-1.5.1.ebuild
new file mode 100644
index 000000000000..a1d9796cbf73
--- /dev/null
+++ b/app-emacs/regress/regress-1.5.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Regression test harness for Emacs Lisp code"
+HOMEPAGE="http://www.emacswiki.org/emacs/WikifiedEmacsLispList"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-1+"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc x86"
+
+ELISP_PATCHES="${PV}-regress.el-gentoo.patch"
+SITEFILE="50${PN}-gentoo.el"