summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/rust-mode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/rust-mode')
-rw-r--r--app-emacs/rust-mode/Manifest1
-rw-r--r--app-emacs/rust-mode/files/50rust-mode-gentoo.el3
-rw-r--r--app-emacs/rust-mode/metadata.xml9
-rw-r--r--app-emacs/rust-mode/rust-mode-1_beta20150411.ebuild17
4 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/rust-mode/Manifest b/app-emacs/rust-mode/Manifest
new file mode 100644
index 000000000000..5cbb71c204cc
--- /dev/null
+++ b/app-emacs/rust-mode/Manifest
@@ -0,0 +1 @@
+DIST rust-mode-1_beta20150411.tar.gz 18155 SHA256 ac29e082fa09a98f864213553685bd085fe48ba3ec871032ef3cec19b2388c3a SHA512 fc9fe74ba4924cf54664f37c5a88d86b38e17e4ad5e0d4d924afd7f3c8428764dece81cfbe40397460685859f34c3eb841b2c83aef8f34526f4ed3f065cc504e WHIRLPOOL a4ba69d96701bc48049bb16513b71a836cd2faf197f346d6c4f7fadcb18cf9dc4143e6f82e965d6875c3913f16cda3a4cce2dc83821885a0fa2e4bcfb5ce74a1
diff --git a/app-emacs/rust-mode/files/50rust-mode-gentoo.el b/app-emacs/rust-mode/files/50rust-mode-gentoo.el
new file mode 100644
index 000000000000..0df93798a429
--- /dev/null
+++ b/app-emacs/rust-mode/files/50rust-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'rust-mode "rust-mode" nil t)
+(add-to-list 'auto-mode-alist '("\\.rs\\'" . rust-mode))
diff --git a/app-emacs/rust-mode/metadata.xml b/app-emacs/rust-mode/metadata.xml
new file mode 100644
index 000000000000..b1bfa491b811
--- /dev/null
+++ b/app-emacs/rust-mode/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>emacs</herd>
+ <maintainer>
+ <email>jauhien@gentoo.org</email>
+ <name>Jauhien Piatlicki</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-emacs/rust-mode/rust-mode-1_beta20150411.ebuild b/app-emacs/rust-mode/rust-mode-1_beta20150411.ebuild
new file mode 100644
index 000000000000..fb89009283d0
--- /dev/null
+++ b/app-emacs/rust-mode/rust-mode-1_beta20150411.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="A major emacs mode for editing Rust source code"
+HOMEPAGE="http://www.rust-lang.org/"
+SRC_URI="http://dev.gentoo.org/~jauhien/distfiles/${P}.tar.gz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"