summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/template
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/template')
-rw-r--r--app-emacs/template/Manifest1
-rw-r--r--app-emacs/template/files/50template-gentoo.el20
-rw-r--r--app-emacs/template/metadata.xml8
-rw-r--r--app-emacs/template/template-3.1c-r1.ebuild31
4 files changed, 60 insertions, 0 deletions
diff --git a/app-emacs/template/Manifest b/app-emacs/template/Manifest
new file mode 100644
index 000000000000..69101a66716e
--- /dev/null
+++ b/app-emacs/template/Manifest
@@ -0,0 +1 @@
+DIST template-3.1c.tar.gz 37903 SHA256 d71885ec8d230a5a7cc909f052b97ed7cc30423ca0e2647392424dfd10459845 SHA512 d9fee39b67ff986d7c2dccbd09af3ce208f0e1a616a406fefefe4a6399f69a3527fa5609e87d41f7ceec5bf95818a62cb8da62994b28945998f8a9074821914c WHIRLPOOL 57043085455aefc5a378fa0d48525d823345932d67c34ceee1c5106481d468c1e9fb8559d511f4184d326e71bd46b9416d92f0c080de04607f559da34c163683
diff --git a/app-emacs/template/files/50template-gentoo.el b/app-emacs/template/files/50template-gentoo.el
new file mode 100644
index 000000000000..3da76196f42e
--- /dev/null
+++ b/app-emacs/template/files/50template-gentoo.el
@@ -0,0 +1,20 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'template-single-comment "template"
+ "Decorate the comment in the current line with dashes and alike." t)
+(autoload 'template-block-comment "template"
+ "Decorate the current block of comment-only lines with dashes and alike." t)
+(autoload 'template-update-header "template"
+ "Replace old file name in header with current file name." t)
+(autoload 'template-expand-template "template"
+ "Expand template file TEMPLATE and insert result in current buffer." t)
+(autoload 'template-new-file "template"
+ "Open a new file FILE by using a TEMPLATE." t)
+(autoload 'template-initialize "template"
+ "Initialized package template. See variable `template-initialize'." t)
+
+(setq template-default-directories
+ (list (if (and (not (file-directory-p "~/.templates/"))
+ (file-directory-p "~/lib/templates"))
+ (expand-file-name "~/lib/templates/")
+ (expand-file-name "~/.templates/"))
+ "@SITEETC@/templates"))
diff --git a/app-emacs/template/metadata.xml b/app-emacs/template/metadata.xml
new file mode 100644
index 000000000000..62541310d2d2
--- /dev/null
+++ b/app-emacs/template/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<upstream>
+ <remote-id type="sourceforge">emacs-template</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/template/template-3.1c-r1.ebuild b/app-emacs/template/template-3.1c-r1.ebuild
new file mode 100644
index 000000000000..21420649b812
--- /dev/null
+++ b/app-emacs/template/template-3.1c-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Use templates, decorate comments, auto-update buffers"
+HOMEPAGE="http://emacs-template.sourceforge.net/"
+SRC_URI="mirror://sourceforge/emacs-template/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile lisp/*.el
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ insinto "${SITEETC}/${PN}"
+ doins -r templates
+ dodoc README lisp/ChangeLog
+}