summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-25 02:52:52 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-25 03:27:22 +0100
commit5955812a352bd04cd017ab5591b75cc49937693f (patch)
treedd1a96f5c2ec3b868bd9a7ab55d8ff317f85325e /app-emacs/transient
parentapp-emacs/elpher: sync live 9999 version (diff)
downloadgentoo-5955812a352bd04cd017ab5591b75cc49937693f.tar.gz
gentoo-5955812a352bd04cd017ab5591b75cc49937693f.tar.bz2
gentoo-5955812a352bd04cd017ab5591b75cc49937693f.zip
app-emacs/transient: bump to 0.6.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/transient')
-rw-r--r--app-emacs/transient/Manifest1
-rw-r--r--app-emacs/transient/transient-0.6.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/transient/Manifest b/app-emacs/transient/Manifest
index 438afd037634..3c933457110d 100644
--- a/app-emacs/transient/Manifest
+++ b/app-emacs/transient/Manifest
@@ -1 +1,2 @@
DIST transient-0.5.3.tar.gz 133756 BLAKE2B 4dfe8df4ec72328f1227fb4f885345709e5686854d5caf8c103ef6081b4a6858de29f33292d7a06acdf0c5f608aaaa5311e739122cb10f39e1af9b55d407eb82 SHA512 d6767b36443fdc76703e028613c2bf13de8a55258506091cfc7506e7a2bdb98bd38f387684856a3860201935bdf305c0429716ce250712c5df27cf6d10064bbf
+DIST transient-0.6.0.tar.gz 136259 BLAKE2B a983ec4b42de10f9adfc71180bbd8df83a80d5593e199999b8435fc6da72f2007c78c40b5207a6957e961642699ca0752795a57f3313e0b3f245467fd2e70261 SHA512 a2709b1e6d620f46ff84a15807936bc9264792365ec8dd6633a2419ff094f5cdde139fe2f4dcbc8d393a23a2e2697f3fe1ea1fff7162024169a44a0cff463d75
diff --git a/app-emacs/transient/transient-0.6.0.ebuild b/app-emacs/transient/transient-0.6.0.ebuild
new file mode 100644
index 000000000000..02944ca13d21
--- /dev/null
+++ b/app-emacs/transient/transient-0.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Transient commands abstraction for GNU Emacs"
+HOMEPAGE="https://magit.vc/manual/transient/
+ https://github.com/magit/transient/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG README.org "docs/${PN}.org" )
+ELISP_TEXINFO="docs/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.1
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ elisp_src_prepare
+}