summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-06-02 21:56:20 +0200
committerUlrich Müller <ulm@gentoo.org>2018-06-02 22:02:41 +0200
commitecb88dfaf3b82ead2dac1114eba007ed819fca4c (patch)
tree5f18c29272041706dc947ae93ffe64cb069e218a /app-emacs/yasnippet-snippets/yasnippet-snippets-0.3.ebuild
parentapp-emacs/yasnippet: Version bump. (diff)
downloadgentoo-ecb88dfaf3b82ead2dac1114eba007ed819fca4c.tar.gz
gentoo-ecb88dfaf3b82ead2dac1114eba007ed819fca4c.tar.bz2
gentoo-ecb88dfaf3b82ead2dac1114eba007ed819fca4c.zip
app-emacs/yasnippet-snippets: Initial import.
Package split off from app-emacs/yasnippet. Ebuild contributed by me. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-emacs/yasnippet-snippets/yasnippet-snippets-0.3.ebuild')
-rw-r--r--app-emacs/yasnippet-snippets/yasnippet-snippets-0.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/yasnippet-snippets/yasnippet-snippets-0.3.ebuild b/app-emacs/yasnippet-snippets/yasnippet-snippets-0.3.ebuild
new file mode 100644
index 000000000000..693935e3fecf
--- /dev/null
+++ b/app-emacs/yasnippet-snippets/yasnippet-snippets-0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="A collection of yasnippet snippets for many languages"
+HOMEPAGE="https://github.com/AndreaCrotti/yasnippet-snippets"
+SRC_URI="https://github.com/AndreaCrotti/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-emacs/yasnippet"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() { :; }
+
+src_install() {
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ insinto "${SITEETC}/${PN}"
+ doins -r snippets/.
+ dodoc README.md
+}