summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-08-10 14:12:01 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-08-10 15:37:11 +0200
commit1b2f5032266d1a43753141f506a0953d32312564 (patch)
tree3ca04d40d8c39550fa75a14f198651f4f68732dc /app-emacs
parentapp-admin/rsyslog: bump to 8.2208.0 (diff)
downloadgentoo-1b2f5032266d1a43753141f506a0953d32312564.tar.gz
gentoo-1b2f5032266d1a43753141f506a0953d32312564.tar.bz2
gentoo-1b2f5032266d1a43753141f506a0953d32312564.zip
app-emacs/string-inflection: new package; add version 1.0.16
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/string-inflection/Manifest1
-rw-r--r--app-emacs/string-inflection/files/50string-inflection-gentoo.el2
-rw-r--r--app-emacs/string-inflection/metadata.xml18
-rw-r--r--app-emacs/string-inflection/string-inflection-1.0.16.ebuild27
4 files changed, 48 insertions, 0 deletions
diff --git a/app-emacs/string-inflection/Manifest b/app-emacs/string-inflection/Manifest
new file mode 100644
index 000000000000..cd0edf95606c
--- /dev/null
+++ b/app-emacs/string-inflection/Manifest
@@ -0,0 +1 @@
+DIST string-inflection-1.0.16.tar.gz 6238 BLAKE2B 2a8db2786f9a744329e6e298308a5bec00e6872ed350ab867ff2d2d5176cbb1532d3dec5e09573228808fd5ba3e3214cda063cf01cd52f862043718e8e664bec SHA512 7bd575c02e1917d9f52f49c4409150dbc9d097968304e687eb1145520ed88dee0bc359bbc85883dd1c167e8918440c91d1f362983f0a35f99feff61c85a08ca8
diff --git a/app-emacs/string-inflection/files/50string-inflection-gentoo.el b/app-emacs/string-inflection/files/50string-inflection-gentoo.el
new file mode 100644
index 000000000000..df8f2cee5137
--- /dev/null
+++ b/app-emacs/string-inflection/files/50string-inflection-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "string-inflection-autoloads" nil t)
diff --git a/app-emacs/string-inflection/metadata.xml b/app-emacs/string-inflection/metadata.xml
new file mode 100644
index 000000000000..cd4c3ed5c6ab
--- /dev/null
+++ b/app-emacs/string-inflection/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This Emacs package provides convenient methods for manipulating the naming
+ style of a symbol. It supports different naming conventions such as: camel
+ case, Pascal case, all upper case, lower case separated by underscore.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/akicho8/string-inflection/issues/</bugs-to>
+ <remote-id type="github">akicho8/string-inflection</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/string-inflection/string-inflection-1.0.16.ebuild b/app-emacs/string-inflection/string-inflection-1.0.16.ebuild
new file mode 100644
index 000000000000..74a4f359e8e7
--- /dev/null
+++ b/app-emacs/string-inflection/string-inflection-1.0.16.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Convert symbol names between different naming conventions"
+HOMEPAGE="https://github.com/akicho8/string-inflection/"
+SRC_URI="https://github.com/akicho8/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.org HISTORY.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ # "test/string-inflection-test.el" calls "(ert-run-tests-batch t)"
+ ${EMACS} ${EMACSFLAGS} -L . -L test -l test/${PN}-test.el || die
+}