summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-05-24 14:03:07 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-05-24 14:35:04 +0200
commit47ccf8542520c09be9a270d13b9569b67c7196f1 (patch)
tree60b5d3a1e9dbfb5796aa7abb7a3265b5466954de /app-emacs
parentapp-emacs/with-simulated-input: new package; add version 3.0 (diff)
downloadgentoo-47ccf8542520c09be9a270d13b9569b67c7196f1.tar.gz
gentoo-47ccf8542520c09be9a270d13b9569b67c7196f1.tar.bz2
gentoo-47ccf8542520c09be9a270d13b9569b67c7196f1.zip
app-emacs/parsebib: new package; add version 3.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/parsebib/Manifest1
-rw-r--r--app-emacs/parsebib/files/50parsebib-gentoo.el1
-rw-r--r--app-emacs/parsebib/metadata.xml17
-rw-r--r--app-emacs/parsebib/parsebib-3.1.ebuild28
4 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/parsebib/Manifest b/app-emacs/parsebib/Manifest
new file mode 100644
index 000000000000..36cc33b12a9d
--- /dev/null
+++ b/app-emacs/parsebib/Manifest
@@ -0,0 +1 @@
+DIST parsebib-3.1.tar.gz 19298 BLAKE2B 1588a9ef6e1642a612be2abb340d9127f8b8542ac2edda0deb5d9be28903443a33de877e44cefceba110332c022b8e4885a2927f172a447f035e9a5c0e65b5a5 SHA512 10dc25831693d271582b2d561401399e12ac3ccbc994dc95ae22fec800e1b242461deaa6a1c0ae5b20a1834baf88017b3ee42f1a53ac5d73f73a2f69c050c6c2
diff --git a/app-emacs/parsebib/files/50parsebib-gentoo.el b/app-emacs/parsebib/files/50parsebib-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/parsebib/files/50parsebib-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/parsebib/metadata.xml b/app-emacs/parsebib/metadata.xml
new file mode 100644
index 000000000000..0892b478df27
--- /dev/null
+++ b/app-emacs/parsebib/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/joostkremers/parsebib/issues/</bugs-to>
+ <remote-id type="github">joostkremers/parsebib</remote-id>
+ </upstream>
+ <longdescription>
+ Parsebib is an Elisp library for reading bibliographic database files. It
+ supports both BibTeX / biblatex (.bib) files and CSL-JSON (.json) files.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-emacs/parsebib/parsebib-3.1.ebuild b/app-emacs/parsebib/parsebib-3.1.ebuild
new file mode 100644
index 000000000000..6d23c9db04f0
--- /dev/null
+++ b/app-emacs/parsebib/parsebib-3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Emacs Lisp library for reading .bib files"
+HOMEPAGE="https://github.com/joostkremers/parsebib/"
+SRC_URI="https://github.com/joostkremers/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/ert-runner )"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}