summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2016-05-06 15:19:25 +0200
committerUlrich Müller <ulm@gentoo.org>2016-05-06 15:19:39 +0200
commit654863a00e893f2e060adfdc8fbecd37c6e93349 (patch)
tree82744d839a9e81772acc5bdb6dc502ca709d0683 /app-emacs
parentapp-text/po4a: revbump to vn. 0.45-r3 (diff)
downloadgentoo-654863a00e893f2e060adfdc8fbecd37c6e93349.tar.gz
gentoo-654863a00e893f2e060adfdc8fbecd37c6e93349.tar.bz2
gentoo-654863a00e893f2e060adfdc8fbecd37c6e93349.zip
app-emacs/emacs-daemon: Version bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/emacs-daemon/Manifest1
-rw-r--r--app-emacs/emacs-daemon/emacs-daemon-0.22.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-emacs/emacs-daemon/Manifest b/app-emacs/emacs-daemon/Manifest
index 2b3fd2b3a005..76f4f98b81de 100644
--- a/app-emacs/emacs-daemon/Manifest
+++ b/app-emacs/emacs-daemon/Manifest
@@ -1,2 +1,3 @@
DIST emacs-daemon-0.20.tar.xz 5120 SHA256 5c0f0bc9a1fab391657737fc3b6af4088eff1ead2e05987fe50e02f5b6e50eb3 SHA512 ac1bfc543f38dd86aeef544a8d03aa2f2a6cb02ee2042ecb3f339baed98294deac1fc6d3d002e654f3d9f32f00379c4de40efa226ddd07715aee7fe0fcb41e43 WHIRLPOOL 5941c1ea18d238275aab312123eb598f3d3265f279674191a75bec6bfd6efeebadb20dc7e6db6454a9da10ed8e98b2916fad195741b4d5fddbb270528e040d63
DIST emacs-daemon-0.21.tar.xz 5212 SHA256 e07c24d3a92f77d49cecaffdc9dc20d9268505d4ee4879557d0656e6b3c7acd3 SHA512 7131cbd78bb2f11ce3dc5686a3729b8ec11a673e9011c70d72bc04bd5d36373507c9f446ef100d2d37b569850740bf4fb68e06c9e78f3a3bc2b9cdfef8418062 WHIRLPOOL 5c51f985c460a440e6f2b282ad7d289700f621ee1a90c023b4a6f8f317cfd29297ba20f6a8714f27746ee41f9cbae02f200c8bfd39b26d32b0d1c20a56fba48b
+DIST emacs-daemon-0.22.tar.xz 5276 SHA256 62743bc32f48bd5406dedb1d5356e7959c413dbc295977de0315a6ea8c1c6272 SHA512 f013cd00d3a24ca348bf718dd20dec7bea89107c0a27c921d6b58595b611991830604fc658d57681708218fbee1dae6dd0b277a2a9da67639e3553e0fd133094 WHIRLPOOL ccc9a7bc1d378b4b64873f9458284bef9008b1380a58700d5210404a216a62fe98d0b4547e28a2f52d0b3e958b45c84e8654eddb4fab48854629cb513462b948
diff --git a/app-emacs/emacs-daemon/emacs-daemon-0.22.ebuild b/app-emacs/emacs-daemon/emacs-daemon-0.22.ebuild
new file mode 100644
index 000000000000..0374115cf6c2
--- /dev/null
+++ b/app-emacs/emacs-daemon/emacs-daemon-0.22.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="Gentoo support for Emacs running as a server in the background"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DEPEND=">=virtual/emacs-23"
+RDEPEND="${DEPEND}"
+
+SITEFILE="10${PN}-gentoo.el"
+
+pkg_setup() {
+ local has_daemon has_gtk line
+ has_daemon=$(${EMACS} ${EMACSFLAGS} --eval "(princ (fboundp 'daemonp))")
+ has_gtk=$(${EMACS} ${EMACSFLAGS} --eval "(princ (featurep 'gtk))")
+
+ if [[ ${has_daemon} != t ]]; then
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your current Emacs version does not support running as a daemon which
+ is required for ${CATEGORY}/${PN}.
+ Use "eselect emacs" to select an Emacs version >= 23.
+ EOF
+ elif [[ ${has_gtk} == t ]]; then
+ while read line; do ewarn "${line}"; done <<-EOF
+ Your current Emacs is compiled with GTK+. There is a long-standing bug
+ in GTK+ that prevents Emacs from recovering from X disconnects:
+ <https://bugzilla.gnome.org/show_bug.cgi?id=85715>
+ If you run Emacs as a daemon, then it is strongly recommended that you
+ compile it with the Lucid or the Motif toolkit instead, i.e. with
+ USE="athena Xaw3d -gtk -motif" or USE="motif -gtk -athena -Xaw3d".
+ EOF
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ newinitd emacs.rc emacs
+ newconfd emacs.conf emacs
+ exeinto /usr/libexec/emacs
+ doexe emacs-wrapper.sh emacs-stop.sh
+ elisp-site-file-install "${SITEFILE}"
+ dodoc README ChangeLog
+}