summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-05-29 15:31:46 +0200
committerHans de Graaff <graaff@gentoo.org>2016-05-29 15:32:10 +0200
commit725bcc657fc026420b7e851cdc4163784889f36d (patch)
treebadd61088237c3f55a3f138e513b57bf2621880d /app-emacs
parentx11-apps/whyteboard: Cleanup due to #269417 (diff)
downloadgentoo-725bcc657fc026420b7e851cdc4163784889f36d.tar.gz
gentoo-725bcc657fc026420b7e851cdc4163784889f36d.tar.bz2
gentoo-725bcc657fc026420b7e851cdc4163784889f36d.zip
app-emacs/markdown-mode: add 2.1
Backport upstream patch to not add .text to auto-mode-alist. Add auto-mode-alist entries for .md and .markdown in site-init. Package-Manager: portage-2.2.28
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/markdown-mode/Manifest1
-rw-r--r--app-emacs/markdown-mode/files/50markdown-mode-gentoo.el2
-rw-r--r--app-emacs/markdown-mode/files/markdown-mode-2.1-text-auto-mode.patch23
-rw-r--r--app-emacs/markdown-mode/markdown-mode-2.1.ebuild23
4 files changed, 49 insertions, 0 deletions
diff --git a/app-emacs/markdown-mode/Manifest b/app-emacs/markdown-mode/Manifest
index 1a40b451753f..1b6968ab8135 100644
--- a/app-emacs/markdown-mode/Manifest
+++ b/app-emacs/markdown-mode/Manifest
@@ -1,2 +1,3 @@
DIST markdown-mode-1.8.1.el.xz 18152 SHA256 865d83162cfb39ee06a2e46b3d586e71d144d360e8f2f1cdf72bdb5923ededc0 SHA512 1e679a409fa5a7f6f622e4a554d74ea1820ba1e82eb77d3ce6b33d5494350232a2b165c9f002a076d4ce97138584381938d5c2ccac4161131ffba82da5091946 WHIRLPOOL b8b05f9b8ffa1db6c20fda46e6058fb7b05ba64f9bd921ae310d274c4be0887c29ab180cbd984c1ea21020be4e8af619a91e4a8c0a8a33d280298ba9cfbec162
DIST markdown-mode-2.0.el.xz 39508 SHA256 a24f06f4aa2f1d4847e045a54c25c73f503ed89c0f8954b934b2b6c658357819 SHA512 eaad1561c5a84f47cd07318f0c80454d28a59becc0372453ec1412511879335a5717d1531895fe969c5d2fe7a4aac5a9e55ee727dcee621ba203737ca9182f3d WHIRLPOOL 14d15b9ad20c1f857e99056fbfd5c2305a7ba579a8210a73d10806589e201e5e881a33b49ea31277fe354c2bb8cdab090811c8c27aca64811248596927c82994
+DIST markdown-mode-2.1.el.xz 50484 SHA256 c4b4fb632d1354ea5ed6d8500a85326c05e24d0343cc4fd5d54860f70dc67022 SHA512 3f0d68b03408281e49c9dbf4d26b8c1f766aa675efea6789b13722c7b1d831af35d3ea30ac071be00242279bca31d04fe92a28b901698fe2072d4504d9901253 WHIRLPOOL 909b542f6523b47bae8b27445b3d8fc0f82a6fe6867e16b471c68f067fbc4f7918f482b0e373ea0b5d0763bbf5b0275e15427ac76007a6329b3aa8dfcebebdeb
diff --git a/app-emacs/markdown-mode/files/50markdown-mode-gentoo.el b/app-emacs/markdown-mode/files/50markdown-mode-gentoo.el
index 6a83e601b026..fb4a5cba03e8 100644
--- a/app-emacs/markdown-mode/files/50markdown-mode-gentoo.el
+++ b/app-emacs/markdown-mode/files/50markdown-mode-gentoo.el
@@ -1,3 +1,5 @@
(add-to-list 'load-path "@SITELISP@")
(autoload 'markdown-mode "markdown-mode"
"Major mode for editing Markdown files" t)
+(add-to-list 'auto-mode-alist '("\\.markdown\\'" . markdown-mode))
+(add-to-list 'auto-mode-alist '("\\.md\\'" . markdown-mode))
diff --git a/app-emacs/markdown-mode/files/markdown-mode-2.1-text-auto-mode.patch b/app-emacs/markdown-mode/files/markdown-mode-2.1-text-auto-mode.patch
new file mode 100644
index 000000000000..91449c6daa54
--- /dev/null
+++ b/app-emacs/markdown-mode/files/markdown-mode-2.1-text-auto-mode.patch
@@ -0,0 +1,23 @@
+From a70e74e0eedb436c4126ac69b0beaa4ab848b78e Mon Sep 17 00:00:00 2001
+From: Steve Purcell <steve@sanityinc.com>
+Date: Mon, 14 Mar 2016 09:18:16 +1300
+Subject: Remove autoload for .text
+
+While .md and .markdown are clearly markdown files, the handling of .text is not a choice that markdown-mode should be making on the user's behalf without any opportunity to prevent it.
+
+diff --git a/markdown-mode.el b/markdown-mode.el
+index b7a32cc..978e040 100644
+--- a/markdown-mode.el
++++ b/markdown-mode.el
+@@ -6634,8 +6634,6 @@ BEG and END are the limits of scanned region."
+ ;;;###autoload
+ (add-to-list 'auto-mode-alist '("\\.markdown\\'" . markdown-mode))
+ ;;;###autoload
+-(add-to-list 'auto-mode-alist '("\\.text\\'" . markdown-mode))
+-;;;###autoload
+ (add-to-list 'auto-mode-alist '("\\.md\\'" . markdown-mode))
+
+
+--
+cgit v0.10.2
+
diff --git a/app-emacs/markdown-mode/markdown-mode-2.1.ebuild b/app-emacs/markdown-mode/markdown-mode-2.1.ebuild
new file mode 100644
index 000000000000..2770855453bd
--- /dev/null
+++ b/app-emacs/markdown-mode/markdown-mode-2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Major mode for editing Markdown-formatted text files"
+HOMEPAGE="http://jblevins.org/projects/markdown-mode/"
+# Cannot use this url because its hash differ about every five minutes
+# SRC_URI="http://jblevins.org/git/${PN}.git/snapshot/${P}.tar.gz"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="|| ( dev-python/markdown2 dev-python/markdown )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+ELISP_PATCHES=( ${P}-text-auto-mode.patch )