summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-02-15 21:40:05 +0100
committerUlrich Müller <ulm@gentoo.org>2018-02-15 21:45:45 +0100
commit770cab1f4c6dba4e22a10af6c2a6df51d40a61ed (patch)
treef5be2f83dfd246d918c68d5c9ae04134a2c57ff7 /app-emacs
parentpackage.mask: dev-php/PEAR-* Last rites (diff)
downloadgentoo-770cab1f4c6dba4e22a10af6c2a6df51d40a61ed.tar.gz
gentoo-770cab1f4c6dba4e22a10af6c2a6df51d40a61ed.tar.bz2
gentoo-770cab1f4c6dba4e22a10af6c2a6df51d40a61ed.zip
app-emacs/auctex: Version bump.
auctex-11.92 is the last version supporting Emacs 23 and will be the next stable candidate. Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/auctex/Manifest2
-rw-r--r--app-emacs/auctex/auctex-11.92.ebuild60
-rw-r--r--app-emacs/auctex/auctex-12.1.ebuild61
3 files changed, 123 insertions, 0 deletions
diff --git a/app-emacs/auctex/Manifest b/app-emacs/auctex/Manifest
index bab5a046220a..254ccad9faa6 100644
--- a/app-emacs/auctex/Manifest
+++ b/app-emacs/auctex/Manifest
@@ -1,3 +1,5 @@
DIST auctex-11.88.tar.gz 1302836 BLAKE2B ffb7d3ff8d5b2cc8208bddf782a736c2d347be399fe3702c6bcc2e7cda3562b667bc42204ceac9ec512587f6ecf28fd7a6d1b720ce8b5de9ef815d6af772393c SHA512 30c422b52b3fc698e453ada9643038dd30978f6b1a99f5118a53ae5b939d63246adcb1937f0e5c4cf166477dca78fa17d721402a90c833c9e91d75072ae0f67d
DIST auctex-11.89.tar.gz 1332904 BLAKE2B 1f89b9ee81d5cf5c896ce38731bb43978827452d607f7b61b995d55911bc36ca0071d0abadb293234e9c3f41bb8a57b92951e4eb0c3d7f13db063cb286920f37 SHA512 a78ddefb46c1eb271646f3c4e723f49a913e391eb58263df3d3de272bc1ad5b70c0a9de682f28124aa5a48b36c030b3e83425667ee1a1973a054ff03ef1d8be9
DIST auctex-11.90.tar.gz 1437331 BLAKE2B 9f4c236132fcebb2c6996d3105e6e6d095e29e1ff531ad9d55c609b972a0a3cea0a580830c950ab6f59b0eda50625cc617e868c82a00705f41f472c08b13a7c3 SHA512 b90b246a6193570897102d8f95396b35c8b899fc594446f2455469b9c58ca8fd1dafbb852c6f167fd8500261f007c8a66531bb04582d7a5c4a50a15933b70c83
+DIST auctex-11.92.tar.gz 1486606 BLAKE2B 6e34d1da3bacad8f2baee2f13eb44a5b617a342c294ef4d7ba28059b678510e1d161f3f02fbcf38128c09ab4996a035e5ec28898134b967d88ad621b8b477845 SHA512 758bf82903ba0499decf0ade77c7ac70865132a24195d7e8794538b7857c448811b7ef26149a915b60ed3ee34c2ebaddb3282a320bd459c9ee3f461d6ee9b84e
+DIST auctex-12.1.tar.gz 1476296 BLAKE2B 1dd5db94b5b7bb572919fdcb6c7dd2ea4d17f816204bedc69756610b80370ca748a06ab100ef8221107605a5e464b6a8c2587b728ba6a964776ea6dfeb7f7165 SHA512 4c27a3b16eaf98db164832497c497576fcabb274b24c6eb3060625b7711b1de91fce9a52f7c7caaec77a93768a6ce2ec173ab1ccb72f4c56c51cc4740d380d97
diff --git a/app-emacs/auctex/auctex-11.92.ebuild b/app-emacs/auctex/auctex-11.92.ebuild
new file mode 100644
index 000000000000..7cb97b6dd627
--- /dev/null
+++ b/app-emacs/auctex/auctex-11.92.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="Extensible package for writing and formatting TeX files in Emacs"
+HOMEPAGE="https://www.gnu.org/software/auctex/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="preview-latex"
+
+DEPEND="virtual/latex-base
+ preview-latex? (
+ app-text/dvipng
+ app-text/ghostscript-gpl
+ )"
+RDEPEND="${DEPEND}"
+
+TEXMF="/usr/share/texmf-site"
+
+src_configure() {
+ econf --with-emacs \
+ --with-auto-dir="${EPREFIX}/var/lib/auctex" \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-packagelispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-packagedatadir="${EPREFIX}${SITEETC}/${PN}" \
+ --with-texmf-dir="${EPREFIX}${TEXMF}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --disable-build-dir-test \
+ $(use_enable preview-latex preview)
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}"/fonts
+ emake
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
+ if use preview-latex; then
+ elisp-site-file-install "${FILESDIR}/60${PN}-gentoo.el"
+ fi
+ dodoc ChangeLog* CHANGES FAQ INSTALL PROBLEMS.preview README RELEASE TODO
+}
+
+pkg_postinst() {
+ use preview-latex && texmf-update
+ elisp-site-regen
+}
+
+pkg_postrm(){
+ use preview-latex && texmf-update
+ elisp-site-regen
+}
diff --git a/app-emacs/auctex/auctex-12.1.ebuild b/app-emacs/auctex/auctex-12.1.ebuild
new file mode 100644
index 000000000000..1b6155aa84d1
--- /dev/null
+++ b/app-emacs/auctex/auctex-12.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Extensible package for writing and formatting TeX files in Emacs"
+HOMEPAGE="https://www.gnu.org/software/auctex/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="preview-latex"
+
+DEPEND="virtual/latex-base
+ preview-latex? (
+ app-text/dvipng
+ app-text/ghostscript-gpl
+ )"
+RDEPEND="${DEPEND}"
+
+TEXMF="/usr/share/texmf-site"
+
+src_configure() {
+ econf --with-emacs \
+ --with-auto-dir="${EPREFIX}/var/lib/auctex" \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-packagelispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-packagedatadir="${EPREFIX}${SITEETC}/${PN}" \
+ --with-texmf-dir="${EPREFIX}${TEXMF}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --disable-build-dir-test \
+ $(use_enable preview-latex preview)
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}"/fonts
+ emake
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
+ if use preview-latex; then
+ elisp-site-file-install "${FILESDIR}/60${PN}-gentoo.el"
+ fi
+ dodoc ChangeLog* CHANGES FAQ INSTALL PROBLEMS.preview README RELEASE TODO
+}
+
+pkg_postinst() {
+ use preview-latex && texmf-update
+ elisp-site-regen
+}
+
+pkg_postrm(){
+ use preview-latex && texmf-update
+ elisp-site-regen
+}