summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-21 16:53:23 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-21 16:56:25 +0200
commita87eee1bf0e4a9bf25a191825ce25d4655da34c3 (patch)
treeb8af1fadf9e399ad41fc9e216fe26582868eb466 /app-emacs
parentapp-emacs/edit-indirect: new package; add 0.1.10 (diff)
downloadgentoo-a87eee1bf0e4a9bf25a191825ce25d4655da34c3.tar.gz
gentoo-a87eee1bf0e4a9bf25a191825ce25d4655da34c3.tar.bz2
gentoo-a87eee1bf0e4a9bf25a191825ce25d4655da34c3.zip
app-emacs/markdown-mode: edit-indirect optfeature; format
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/markdown-mode/markdown-mode-2.5-r1.ebuild33
1 files changed, 24 insertions, 9 deletions
diff --git a/app-emacs/markdown-mode/markdown-mode-2.5-r1.ebuild b/app-emacs/markdown-mode/markdown-mode-2.5-r1.ebuild
index 82e1e0ff7742..e11c0d58dab2 100644
--- a/app-emacs/markdown-mode/markdown-mode-2.5-r1.ebuild
+++ b/app-emacs/markdown-mode/markdown-mode-2.5-r1.ebuild
@@ -3,11 +3,12 @@
EAPI=8
-inherit elisp
+inherit elisp optfeature
DESCRIPTION="Major mode for editing Markdown-formatted text files"
HOMEPAGE="https://jblevins.org/projects/markdown-mode/"
-SRC_URI="https://github.com/jrblevin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/jrblevin/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
@@ -15,19 +16,33 @@ KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="|| (
+RDEPEND="
+ || (
dev-python/markdown2
dev-python/markdown
virtual/pandoc
- )"
-BDEPEND="test? (
- virtual/pandoc
- || ( app-text/aspell[l10n_en] app-text/hunspell[l10n_en] )
-)"
+ )
+"
+BDEPEND="
+ test? (
+ virtual/pandoc
+ || (
+ app-text/aspell[l10n_en]
+ app-text/hunspell[l10n_en]
+ )
+ )
+"
PATCHES=(
"${FILESDIR}"/${PN}-2.5-markdown-command.patch
"${FILESDIR}"/${PN}-2.5-test.patch
)
+
+DOCS=( CHANGES.md CONTRIBUTING.md README.md )
SITEFILE="50${PN}-gentoo.el"
-DOCS="CHANGES.md CONTRIBUTING.md README.md"
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ optfeature "editing Markdown source code blocks" app-emacs/edit-indirect
+}