summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-10-17 14:36:25 +0200
committerUlrich Müller <ulm@gentoo.org>2019-10-17 15:19:01 +0200
commitb989045c195065c35a387db01019b0db073acc53 (patch)
treee73d732c59115387ecc3add2efa8f81625d2022d /app-emacs
parentapp-emacs/mpg123-el: Remove old. (diff)
downloadgentoo-b989045c195065c35a387db01019b0db073acc53.tar.gz
gentoo-b989045c195065c35a387db01019b0db073acc53.tar.bz2
gentoo-b989045c195065c35a387db01019b0db073acc53.zip
app-emacs/emms: Bump to version 5.2.
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/emms/Manifest1
-rw-r--r--app-emacs/emms/emms-5.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/emms/Manifest b/app-emacs/emms/Manifest
index 0750f8683eca..cf353b2f1356 100644
--- a/app-emacs/emms/Manifest
+++ b/app-emacs/emms/Manifest
@@ -1,2 +1,3 @@
DIST emms-4.3.tar.gz 287153 BLAKE2B 2b8dab4f18ea7a6eb4e0b982d795d5f16dcdbe39dc091e6f6fe056cf1143b11620ef8ee4fc83612224c6674978747b8c96575e797f0779b6fab71f46f921f918 SHA512 fd674e8637700d0a08cbdf0253ffd285623ba8181fac389eb94a701091ce25b071f995baa4fd68d60528dbbb90bbf034705bf52b41d9d5edd7af12c2c99418ed
DIST emms-4.4.tar.gz 288922 BLAKE2B d86cd9124f1d92d9d91aa96c45f7fd5e86776ff5f15cfa5e139eb40bc72e673f394b3d5209e64da62d3ab02ef18d6ac690e1d4e4273f3aad9c53b7e5ac4e7839 SHA512 d0aaac80728b542366885916e43c2c50302a5a5d6c9e35ff53a5b46a7185fda19459ea28f0d77929920873d7d9732fa531a4ef50f5052ed4df42cc474d14d0ba
+DIST emms-5.2.tar.gz 314013 BLAKE2B 171166ee85ed34c9c2015f92ba395dda4bcf635c4db01b6aea3c09afe0f6db73eb79f38ee8c110ea45c3cbbc5167ecec18eb8d039b8925dc0447da8746ad5354 SHA512 5ff70d129d4ec44d79e574eb4eddb4605fd75e98fa190770a841efd3d430e0cf4d55787d567eaff0b5746af68fb7b19a4d2dfd37de678b97e1b3c8db3690c768
diff --git a/app-emacs/emms/emms-5.2.ebuild b/app-emacs/emms/emms-5.2.ebuild
new file mode 100644
index 000000000000..332e0d00a88d
--- /dev/null
+++ b/app-emacs/emms/emms-5.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="The Emacs Multimedia System"
+HOMEPAGE="https://www.gnu.org/software/emms/
+ https://www.emacswiki.org/emacs/EMMS"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="media-libs/taglib"
+DEPEND="${RDEPEND}"
+
+# EMMS can use almost anything for playing media files therefore the dependency
+# possibilities are so broad that we refrain from setting anything explicitly
+# in DEPEND/RDEPEND.
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
+ all emms-print-metadata
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo doc/emms.info*
+ dobin src/emms-print-metadata
+ doman emms-print-metadata.1
+ dodoc AUTHORS ChangeLog NEWS README THANKGNU
+}