summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-05-13 23:07:02 +0200
committerUlrich Müller <ulm@gentoo.org>2019-05-13 23:08:52 +0200
commite870ba4d34bec0a85f25342924d842db3c77baff (patch)
tree8190a8d7400406dcff8c8e63485aada435797584 /app-emacs
parentdev-python/tox: fix broken manifest (diff)
downloadgentoo-e870ba4d34bec0a85f25342924d842db3c77baff.tar.gz
gentoo-e870ba4d34bec0a85f25342924d842db3c77baff.tar.bz2
gentoo-e870ba4d34bec0a85f25342924d842db3c77baff.zip
app-emacs/blogmax: Version bump.
No new release since 2011, therefore snapshot from git. Bug: https://bugs.gentoo.org/685872 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/blogmax/Manifest1
-rw-r--r--app-emacs/blogmax/blogmax-20170321.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/blogmax/Manifest b/app-emacs/blogmax/Manifest
index 601a495e8329..589023413a9c 100644
--- a/app-emacs/blogmax/Manifest
+++ b/app-emacs/blogmax/Manifest
@@ -1 +1,2 @@
DIST blogmax-20110305.zip 194956 BLAKE2B b5f90254a218fc45b65faa8d5cdc53ec55f092716286a5757f483eed621d2142aeda398449b1c1b9c3acad67575025ce6bf9b9dce42f1d97d35227d13a0aa65e SHA512 dc0529c5d61ea9beaecf9dfdfe0631ae31fb9737845aa81f2ac7c19df7aa30eb7392f73ea96a00b678cd441f0815129bb04d521e697ce2cb3938d8699483d19b
+DIST blogmax-20170321.tar.xz 81704 BLAKE2B f7f45cb0d5981a0af09ad75b8b004aca950dad59efb0182f81596d6777caf31df6089c2cabb856168d5c031c5e60282e9a88f822219f5ec728f5dddc1c6adcb6 SHA512 bca3fd0bb10d98604426b4091831e709b2a731aa2e4cfc0737f14714bc6648a279c1909e1939f4504cf49aa470737458a00da598139d7797128563212997a4c1
diff --git a/app-emacs/blogmax/blogmax-20170321.ebuild b/app-emacs/blogmax/blogmax-20170321.ebuild
new file mode 100644
index 000000000000..1fced845ba4e
--- /dev/null
+++ b/app-emacs/blogmax/blogmax-20170321.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp eutils readme.gentoo-r1
+
+DESCRIPTION="Blogging in Emacs"
+HOMEPAGE="https://billstclair.com/blogmax/index.html"
+# snapshot from https://github.com/billstclair/BlogMax
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+S="${WORKDIR}/${PN}"
+ELISP_REMOVE="*.elc gpl.txt"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ edos2unix *.{el,html,inc,ini,tmpl,txt,xml} docs/*.{html,txt}
+ elisp_src_prepare
+}
+
+src_compile() {
+ elisp-compile blogmax.el
+}
+
+src_install() {
+ elisp-install ${PN} blogmax.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ DOC_CONTENTS="To get started with BlogMax, use the example site file
+ from /usr/share/doc/${PF}/example as a template for your own blog."
+ readme.gentoo_create_doc
+
+ dodoc README
+ dodoc -r docs
+ docinto example
+ dodoc *.{html,inc,ini,png,tmpl,txt,xml}
+}