summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-07-24 11:47:53 +0100
committerMatthew Smith <matthew@gentoo.org>2022-07-24 11:47:53 +0100
commitf5a238b85565e6e0d46f06ee75d320d6f2025232 (patch)
tree0132d9940ec6559ac3d04931b785809a7a813257 /app-emacs
parentnet-mail/mu: add 1.8.7 (diff)
downloadgentoo-f5a238b85565e6e0d46f06ee75d320d6f2025232.tar.gz
gentoo-f5a238b85565e6e0d46f06ee75d320d6f2025232.tar.bz2
gentoo-f5a238b85565e6e0d46f06ee75d320d6f2025232.zip
app-emacs/compat: add 28.1.2.0
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/compat/Manifest1
-rw-r--r--app-emacs/compat/compat-28.1.2.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/compat/Manifest b/app-emacs/compat/Manifest
index c3465f8b913d..7208e4487f42 100644
--- a/app-emacs/compat/Manifest
+++ b/app-emacs/compat/Manifest
@@ -1,2 +1,3 @@
DIST compat-28.1.1.1.tar.gz 71771 BLAKE2B 48feaada7e32f07b425048f8b993b2936450dbed8ba20e0f6319d4b098bcc8007323416bf300221a00fb13ff152698c2beaeea6e743d46b1d32b9c0a016a895c SHA512 e733836934671cb373f70a92a20084622e160f2731c5e5c6ce9df348820261db399da0e78d6b95293d9b6992469e96298e9fe83e331a4caaa377fc6ce61f7040
DIST compat-28.1.1.3.tar.gz 72597 BLAKE2B 82186713370fed7f97eb057cb330d77c1d758224ad37c0b7fbbd21221b0d2ffd68be805483f3e9577866f02079c83a5686918c87a1ed7c67c9acdd64aa3a560b SHA512 d65e5ce666607cd6d26cf771d6878caeb6641aff0fc924ec901955c1a03b6fe42e3527220448fa92a8d6c3f5bd65e6f915ed4ada1be01a29d7919f916826e48f
+DIST compat-28.1.2.0.tar.gz 72597 BLAKE2B 82186713370fed7f97eb057cb330d77c1d758224ad37c0b7fbbd21221b0d2ffd68be805483f3e9577866f02079c83a5686918c87a1ed7c67c9acdd64aa3a560b SHA512 d65e5ce666607cd6d26cf771d6878caeb6641aff0fc924ec901955c1a03b6fe42e3527220448fa92a8d6c3f5bd65e6f915ed4ada1be01a29d7919f916826e48f
diff --git a/app-emacs/compat/compat-28.1.2.0.ebuild b/app-emacs/compat/compat-28.1.2.0.ebuild
new file mode 100644
index 000000000000..8a61c3a356a2
--- /dev/null
+++ b/app-emacs/compat/compat-28.1.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=2c3233c0e09ef34176787b6e3da4319751ad91e7
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Compatibility libraries for Emacs"
+HOMEPAGE="https://git.sr.ht/~pkal/compat/"
+SRC_URI="https://git.sr.ht/~pkal/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="sys-apps/texinfo"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_compile() {
+ emake compile ${PN}.info
+}
+
+src_test() {
+ local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
+ if [[ "${has_json}" != t ]] ; then
+ local line
+ while read line ; do
+ ewarn "${line}"
+ done <<-EOF
+ Your current Emacs version does not support native JSON parsing,
+ which is required for running tests of ${CATEGORY}/${PN}.
+ Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
+ to select that version.
+ EOF
+ else
+ emake test
+ fi
+}